aboutsummaryrefslogtreecommitdiff
path: root/devel/bsdbuild
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-16 18:34:00 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-16 18:34:00 +0000
commit35e9edfef09e49fecdb680b98aba61fe3c65010e (patch)
tree90626c159a15bb90a3a3a0f96d7c74797dc81fd0 /devel/bsdbuild
parent54a7bea65f6fc3dd02cb33ad8f32c0c6cc4d2bfc (diff)
downloadports-35e9edfef09e49fecdb680b98aba61fe3c65010e.tar.gz
ports-35e9edfef09e49fecdb680b98aba61fe3c65010e.zip
Notes
Diffstat (limited to 'devel/bsdbuild')
-rw-r--r--devel/bsdbuild/Makefile13
-rw-r--r--devel/bsdbuild/distinfo4
-rw-r--r--devel/bsdbuild/files/patch-ManReader__Makefile31
-rw-r--r--devel/bsdbuild/pkg-descr10
-rw-r--r--devel/bsdbuild/pkg-plist24
5 files changed, 35 insertions, 47 deletions
diff --git a/devel/bsdbuild/Makefile b/devel/bsdbuild/Makefile
index 2d791976e31f..fe08843d8164 100644
--- a/devel/bsdbuild/Makefile
+++ b/devel/bsdbuild/Makefile
@@ -1,20 +1,17 @@
# $FreeBSD$
PORTNAME= bsdbuild
-PORTVERSION= 3.0
-PORTREVISION= 2
+PORTVERSION= 3.1
CATEGORIES= devel
MASTER_SITES= http://stable.hypertriton.com/bsdbuild/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= BSD-licensed portable build system
+MAINTAINER= vedge@hypertriton.com
+COMMENT= Portable BSD-style build system
+
+LICENSE= BSD2CLAUSE
USES= perl5 shebangfix
SHEBANG_FILES= *.pl mk/*.pl
GNU_CONFIGURE= yes
-LICENSE= BSD2CLAUSE
-
-CONFIGURE_ARGS= --with-catman=no
-
.include <bsd.port.mk>
diff --git a/devel/bsdbuild/distinfo b/devel/bsdbuild/distinfo
index 63265458a7dc..7efada7eeaa9 100644
--- a/devel/bsdbuild/distinfo
+++ b/devel/bsdbuild/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bsdbuild-3.0.tar.gz) = 202fbadffcab04a395bd4b3cb786720fd034c862ecf74da603ab29fbbe423428
-SIZE (bsdbuild-3.0.tar.gz) = 218099
+SHA256 (bsdbuild-3.1.tar.gz) = d4c562c33cda97f2c5c71ced422f336060a7402237ffc41d84937ca30e942dff
+SIZE (bsdbuild-3.1.tar.gz) = 510668
diff --git a/devel/bsdbuild/files/patch-ManReader__Makefile b/devel/bsdbuild/files/patch-ManReader__Makefile
deleted file mode 100644
index 4cf2fb15ad6e..000000000000
--- a/devel/bsdbuild/files/patch-ManReader__Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
---- ./ManReader/Makefile.orig 2012-07-27 06:21:45.000000000 +0200
-+++ ./ManReader/Makefile 2013-09-25 01:25:39.843961894 +0200
-@@ -5,23 +5,23 @@
- all:
-
- install:
-- @if [ ! -d "${DATADIR}/ManReader" ]; then \
-+ @if [ ! -d "${DESTDIR}${DATADIR}/ManReader" ]; then \
- echo "${INSTALL_DATA_DIR} ${DATADIR}/ManReader"; \
-- ${SUDO} ${INSTALL_DATA_DIR} ${DATADIR}/ManReader; \
-+ ${SUDO} ${INSTALL_DATA_DIR} ${DESTDIR}${DATADIR}/ManReader; \
- fi; \
- for F in ${DATAFILES}; do \
- echo "${INSTALL_DATA} $$F ${DATADIR}/ManReader"; \
-- ${SUDO} ${INSTALL_DATA} $$F ${DATADIR}/ManReader; \
-+ ${SUDO} ${INSTALL_DATA} $$F ${DESTDIR}${DATADIR}/ManReader; \
- done
-
- install-links:
- @if [ ! -d "${DATADIR}/ManReader" ]; then \
- echo "${INSTALL_DATA_DIR} ${DATADIR}/ManReader"; \
-- ${SUDO} ${INSTALL_DATA_DIR} ${DATADIR}/ManReader; \
-+ ${SUDO} ${INSTALL_DATA_DIR} ${DESTDIR}${DATADIR}/ManReader; \
- fi; \
- for F in ${DATAFILES}; do \
- echo "ln -sf `pwd`/$$F ${DATADIR}/ManReader/$$F"; \
-- ${SUDO} ln -sf `pwd`/$$F ${DATADIR}/ManReader/$$F; \
-+ ${SUDO} ln -sf `pwd`/$$F ${DESTDIR}${DATADIR}/ManReader/$$F; \
- done
-
- clean:
diff --git a/devel/bsdbuild/pkg-descr b/devel/bsdbuild/pkg-descr
index 7473a055b11f..009e1aecc7ba 100644
--- a/devel/bsdbuild/pkg-descr
+++ b/devel/bsdbuild/pkg-descr
@@ -2,7 +2,11 @@ BSDBuild is a simple, self-contained and portable build system derived from the
traditional 4.4BSD share/mk files. BSDBuild uses BSD-style makefiles, but
without BSD make extensions (it uses standard Bourne script fragments instead),
so the build system is portable to most operating systems and make flavors.
-Because BSDBuild is implemented as a library, makefiles are edited directly and
-never need to be "regenerated".
-WWW: http://hypertriton.com/bsdbuild/
+Because BSDBuild is implemented as a library, Makefiles never need to be
+recompiled (unless a separate build is requested). BSDBuild can also generate
+pure Bourne ./configure scripts, which function similarly to GNU-style
+configure scripts (as far as end-users are concerned), but are compiled using
+Perl modules instead of macro packages.
+
+WWW: http://bsdbuild.hypertriton.com/
diff --git a/devel/bsdbuild/pkg-plist b/devel/bsdbuild/pkg-plist
index 989fc528ba98..fe4c99c7b67f 100644
--- a/devel/bsdbuild/pkg-plist
+++ b/devel/bsdbuild/pkg-plist
@@ -5,7 +5,6 @@
%%DATADIR%%/BSDBuild/agar-core.pm
%%DATADIR%%/BSDBuild/agar-dev.pm
%%DATADIR%%/BSDBuild/agar-math.pm
-%%DATADIR%%/BSDBuild/agar-rg.pm
%%DATADIR%%/BSDBuild/agar-vg.pm
%%DATADIR%%/BSDBuild/agar.pm
%%DATADIR%%/BSDBuild/alsa.pm
@@ -21,12 +20,14 @@
%%DATADIR%%/BSDBuild/cocoa.pm
%%DATADIR%%/BSDBuild/cracklib.pm
%%DATADIR%%/BSDBuild/crypt.pm
+%%DATADIR%%/BSDBuild/csidl.pm
%%DATADIR%%/BSDBuild/curl.pm
%%DATADIR%%/BSDBuild/cxx.pm
%%DATADIR%%/BSDBuild/db4.pm
%%DATADIR%%/BSDBuild/dlopen.pm
%%DATADIR%%/BSDBuild/dyld.pm
%%DATADIR%%/BSDBuild/edacious.pm
+%%DATADIR%%/BSDBuild/etubestore.pm
%%DATADIR%%/BSDBuild/execvp.pm
%%DATADIR%%/BSDBuild/fastcgi.pm
%%DATADIR%%/BSDBuild/fgetln.pm
@@ -34,6 +35,7 @@
%%DATADIR%%/BSDBuild/flock.pm
%%DATADIR%%/BSDBuild/fontconfig.pm
%%DATADIR%%/BSDBuild/free_null.pm
+%%DATADIR%%/BSDBuild/freesg-rg.pm
%%DATADIR%%/BSDBuild/freesg.pm
%%DATADIR%%/BSDBuild/freetype.pm
%%DATADIR%%/BSDBuild/gcc.pm
@@ -56,6 +58,7 @@
%%DATADIR%%/BSDBuild/glx.pm
%%DATADIR%%/BSDBuild/iconv.pm
%%DATADIR%%/BSDBuild/jpeg.pm
+%%DATADIR%%/BSDBuild/kqueue.pm
%%DATADIR%%/BSDBuild/libbsd.pm
%%DATADIR%%/BSDBuild/libidn.pm
%%DATADIR%%/BSDBuild/limits_h.pm
@@ -65,6 +68,7 @@
%%DATADIR%%/BSDBuild/mgid.pm
%%DATADIR%%/BSDBuild/mmap.pm
%%DATADIR%%/BSDBuild/mysql.pm
+%%DATADIR%%/BSDBuild/nanosleep.pm
%%DATADIR%%/BSDBuild/objc.pm
%%DATADIR%%/BSDBuild/ode.pm
%%DATADIR%%/BSDBuild/open_exlock.pm
@@ -76,6 +80,7 @@
%%DATADIR%%/BSDBuild/portaudio.pm
%%DATADIR%%/BSDBuild/progname.pm
%%DATADIR%%/BSDBuild/pthreads.pm
+%%DATADIR%%/BSDBuild/rand48.pm
%%DATADIR%%/BSDBuild/rmd160.pm
%%DATADIR%%/BSDBuild/sdl.pm
%%DATADIR%%/BSDBuild/sdl_image.pm
@@ -104,13 +109,17 @@
%%DATADIR%%/BSDBuild/sys_queue.pm
%%DATADIR%%/BSDBuild/sys_types.pm
%%DATADIR%%/BSDBuild/syslog.pm
+%%DATADIR%%/BSDBuild/timerfd.pm
+%%DATADIR%%/BSDBuild/uim.pm
%%DATADIR%%/BSDBuild/unistd_h.pm
%%DATADIR%%/BSDBuild/vasprintf.pm
%%DATADIR%%/BSDBuild/vsnprintf.pm
%%DATADIR%%/BSDBuild/wgl.pm
%%DATADIR%%/BSDBuild/winsock.pm
%%DATADIR%%/BSDBuild/x11.pm
+%%DATADIR%%/BSDBuild/xbox.pm
%%DATADIR%%/BSDBuild/xinerama.pm
+%%DATADIR%%/ManReader/Mdoc.pm
%%DATADIR%%/build.common.mk
%%DATADIR%%/build.dep.mk
%%DATADIR%%/build.doc.mk
@@ -133,13 +142,21 @@
%%DATADIR%%/get-version.pl
%%DATADIR%%/hstrip.pl
%%DATADIR%%/install-manpages.sh
+%%DATADIR%%/libtool/Makefile
+%%DATADIR%%/libtool/Makefile.in
+%%DATADIR%%/libtool/README
+%%DATADIR%%/libtool/aclocal.m4
%%DATADIR%%/libtool/config.guess
%%DATADIR%%/libtool/config.sub
%%DATADIR%%/libtool/configure
%%DATADIR%%/libtool/configure.in
-%%DATADIR%%/libtool/ltconfig
+%%DATADIR%%/libtool/install-sh
%%DATADIR%%/libtool/ltmain.sh
-%%DATADIR%%/ManReader/Mdoc.pm
+%%DATADIR%%/libtool/m4/libtool.m4
+%%DATADIR%%/libtool/m4/ltoptions.m4
+%%DATADIR%%/libtool/m4/ltsugar.m4
+%%DATADIR%%/libtool/m4/ltversion.m4
+%%DATADIR%%/libtool/m4/lt~obsolete.m4
%%DATADIR%%/manlinks.pl
%%DATADIR%%/mkconcurrent.pl
%%DATADIR%%/mkdep
@@ -158,6 +175,7 @@ man/man1/uman.1.gz
man/man5/build.common.mk.5.gz
man/man5/build.dep.mk.5.gz
man/man5/build.lib.mk.5.gz
+man/man5/build.man.mk.5.gz
man/man5/build.prog.mk.5.gz
man/man5/build.proj.mk.5.gz
man/man5/build.www.mk.5.gz