aboutsummaryrefslogtreecommitdiff
path: root/devel/cdash/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:09:31 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:09:31 +0000
commit6f19ea33d962cb9c7f02f6dc70cb2b90c4851376 (patch)
tree0a31fa601c3eaa72c092822c2b0eb55ee2cca48c /devel/cdash/Makefile
parent0ad8ecbc940f1c60e885a16f7fb7e9381a328dd0 (diff)
- Convert to OptionsNG [1]
- Re-activate dependencies - Bump PORTREVISION Notified by: http://wiki.freebsd.org/Ports/Options/ConvertingToOptionsNG [1]
Notes
Notes: svn path=/head/; revision=305115
Diffstat (limited to 'devel/cdash/Makefile')
-rw-r--r--devel/cdash/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/devel/cdash/Makefile b/devel/cdash/Makefile
index 231674f7220f..eee15dd22e39 100644
--- a/devel/cdash/Makefile
+++ b/devel/cdash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cdash
PORTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.cdash.org/download/
DISTNAME= CDash-${PORTVERSION}
@@ -16,8 +17,8 @@ COMMENT= A web-based software testing server
LICENSE= BSD
-OPTIONS= MYSQL "Use MySQL" on \
- PGSQL "Use PostgreSQL" off
+OPTIONS_MULTI= DB
+OPTIONS_MULTI_DB= MYSQL PGSQL
USE_ZIP= yes
USE_CMAKE= yes
@@ -25,7 +26,7 @@ CMAKE_OUTSOURCE=yes
CMAKE_ARGS+= -DCDASH_DB_NAME:STRING=cdash \
-DCDASH_DB_LOGIN:STRING=cdash \
-DCDASH_DB_TYPE:STRING=${DB_TYPE}
-#USE_PHP= curl gd xsl
+USE_PHP= curl gd xsl
WRKSRC= ${WRKDIR}/${DISTNAME:S/./-/g}
SUB_FILES= pkg-message
@@ -33,19 +34,15 @@ SUB_LIST+= DB_TYPE=${DB_TYPE}
.include <bsd.port.options.mk>
-.if (!defined(WITH_MYSQL) && !defined(WITH_PGSQL)) || (defined(WITH_MYSQL) && defined(WITH_PGSQL))
-IGNORE= please run 'make config' and select either MYSQL or PGSQL, but not both
-.endif
-
-.if defined(WITH_MYSQL)
-#USE_MYSQL= yes
-#USE_PHP+= mysql
+.if ${PORT_OPTIONS:MMYSQL}
+USE_MYSQL= yes
+USE_PHP+= mysql
DB_TYPE= mysql
.endif
-.if defined(WITH_PGSQL)
-#USE_PGSQL= yes
-#USE_PHP+= pgsql
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PGSQL= yes
+USE_PHP+= pgsql
DB_TYPE= pgsql
.endif