aboutsummaryrefslogtreecommitdiff
path: root/devel/cedet/Makefile
diff options
context:
space:
mode:
authorDryice Dong Liu <dryice@FreeBSD.org>2007-03-22 07:57:43 +0000
committerDryice Dong Liu <dryice@FreeBSD.org>2007-03-22 07:57:43 +0000
commitb0ffbafb981eff4057c1e9dd296293a49b154651 (patch)
tree65fef8f0025927ff8260f788c4136ce2e8e4006a /devel/cedet/Makefile
parent6fc51e5c2b1c2bdbe80441aad96ffca685266b95 (diff)
downloadports-b0ffbafb981eff4057c1e9dd296293a49b154651.tar.gz
ports-b0ffbafb981eff4057c1e9dd296293a49b154651.zip
Notes
Diffstat (limited to 'devel/cedet/Makefile')
-rw-r--r--devel/cedet/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/devel/cedet/Makefile b/devel/cedet/Makefile
index 7f9871c9b4d7..8f93a8e8017b 100644
--- a/devel/cedet/Makefile
+++ b/devel/cedet/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= cedet
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
DISTNAME= ${PORTNAME}-1.0pre3
-MAINTAINER= dryice@dryice.name
+MAINTAINER?= dryice@FreeBSD.org
COMMENT= Collection of Emacs Development Environment Tools
PORTCLASS= master
@@ -36,6 +36,13 @@ SEMANTIC_INFOS= bovine.info grammar-fw.info semantic-appdev.info \
USE_GMAKE= yes
CONFLICTS= eieio* semantic* speedbar*
+.if (${EMACS_PORT_NAME} == "emacs22")
+EXTRA_PATCHES+= ${FILESDIR}/semantic-idle.fix.emacs22.diff
+PLIST_SUB+= EMACS22_HAVE="@comment "
+.else
+PLIST_SUB+= EMACS22_HAVE=""
+.endif
+
do-install:
${MKDIR} ${CEDET_LISPDIR}
@@ -92,10 +99,21 @@ do-install:
# speedbar
${MKDIR} ${CEDET_LISPDIR}/speedbar
+
+# emacs22 have own
+.if (${EMACS_PORT_NAME} == "emacs22")
+ ${RM} -f ${WRKSRC}/speedbar/speedbar.el
+ ${RM} -f ${WRKSRC}/speedbar/speedbar.elc
+.endif
+
.for i in *.el *.elc *.xpm
${INSTALL_DATA} ${WRKSRC}/speedbar/${i} ${CEDET_LISPDIR}/speedbar
.endfor
+
+# emacs22 have own
+.if (${EMACS_PORT_NAME} != "emacs22")
${INSTALL_DATA} ${WRKSRC}/speedbar/speedbar.info ${PREFIX}/info
+.endif
post-install:
@${CAT} ${PKGMESSAGE}