aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /devel/cgit
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Notes
Notes: svn path=/head/; revision=326307
Diffstat (limited to 'devel/cgit')
-rw-r--r--devel/cgit/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index 423cd4bc0977..ad8a1755191e 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -33,6 +33,7 @@ SUB_LIST+= PORTNAME=${PORTNAME}
PLIST_SUB+= PORTNAME=${PORTNAME} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
post-extract:
@${RMDIR} ${WRKSRC}/git
@@ -44,6 +45,11 @@ post-patch:
${WRKSRC}/git/Makefile
@${REINPLACE_CMD} -e 's,/usr,${PREFIX},g' \
-e 's,-Igit,-I.,g' ${WRKSRC}/Makefile
+.if empty(ICONV_LIB)
+ @${REINPLACE_CMD} -e '/NEEDS_LIBICONV = YesPlease/d' \
+ -e '/OLD_ICONV = YesPlease/d' \
+ ${WRKSRC}/git/config.mak.uname
+.endif
post-install:
@${MKDIR} /var/cache/${PORTNAME}
@@ -54,4 +60,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>