aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-27 20:39:56 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-27 20:39:56 +0000
commitc9237e6ef260ee67ff1b24cc55d20578c0d3a775 (patch)
treeb5536d4c8e1bc595de2a78b1e2569983366a3612 /devel/cgit
parent3b1784cbd43e90c832b583974fb503551b5fb275 (diff)
downloadports-c9237e6ef260ee67ff1b24cc55d20578c0d3a775.tar.gz
ports-c9237e6ef260ee67ff1b24cc55d20578c0d3a775.zip
devel/cgit: allow staging
- Allow staging [1] (based on) - Add DOCS option - Remove useless options.mk PR: ports/183369 Submitted by: Kevin Zheng <kevinz5000 gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=331804
Diffstat (limited to 'devel/cgit')
-rw-r--r--devel/cgit/Makefile13
-rw-r--r--devel/cgit/pkg-plist5
2 files changed, 6 insertions, 12 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index cc0bb60dc79c..19c621f57e18 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -29,8 +29,8 @@ SUB_FILES= pkg-message
SUB_LIST+= PORTNAME=${PORTNAME}
PLIST_SUB+= PORTNAME=${PORTNAME} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-extract:
@@ -50,12 +50,7 @@ post-patch:
.endif
post-install:
- @${MKDIR} /var/cache/${PORTNAME}
- @${CHOWN} ${WWWOWN}:${WWWGRP} /var/cache/${PORTNAME}
- @${CAT} ${PKGMESSAGE}
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${DOCSDIR}/
-.endif
+ @${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${STAGEDIR}/${DOCSDIR}/
.include <bsd.port.post.mk>
diff --git a/devel/cgit/pkg-plist b/devel/cgit/pkg-plist
index 2dd56df57b14..08b67beb365c 100644
--- a/devel/cgit/pkg-plist
+++ b/devel/cgit/pkg-plist
@@ -1,8 +1,6 @@
%%WWWDIR%%/cgit.cgi
%%WWWDIR%%/cgit.css
%%WWWDIR%%/cgit.png
-%%PORTDOCS%%%%DOCSDIR%%/cgitrc.5.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
lib/cgit/filters/about-formatting.sh
lib/cgit/filters/commit-links.sh
lib/cgit/filters/html-converters/man2html
@@ -13,6 +11,8 @@ lib/cgit/filters/html-converters/rst2html
lib/cgit/filters/html-converters/txt2html
lib/cgit/filters/syntax-highlighting.py
lib/cgit/filters/syntax-highlighting.sh
+%%PORTDOCS%%%%DOCSDIR%%/cgitrc.5.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/cgit/filters/html-converters/resources
@dirrm lib/cgit/filters/html-converters
@dirrm lib/cgit/filters
@@ -20,4 +20,3 @@ lib/cgit/filters/syntax-highlighting.sh
@dirrm %%WWWDIR%%
@exec mkdir -p /var/cache/%%PORTNAME%%
@exec chown %%WWWOWN%%:%%WWWGRP%% /var/cache/%%PORTNAME%%
-@unexec rmdir /var/cache/%%PORTNAME%% 2>/dev/null || true