aboutsummaryrefslogtreecommitdiff
path: root/devel/chora
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2006-04-15 16:23:50 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2006-04-15 16:23:50 +0000
commitc39f14401355954a0c5d01b7a2a0a655ee06a993 (patch)
tree285584564ec9b81936af2e4de9c9d55fc8bef643 /devel/chora
parentf25b2bf7b337aa5ae1b5ef58078aa0b09b1ee539 (diff)
downloadports-c39f14401355954a0c5d01b7a2a0a655ee06a993.tar.gz
ports-c39f14401355954a0c5d01b7a2a0a655ee06a993.zip
Notes
Diffstat (limited to 'devel/chora')
-rw-r--r--devel/chora/files/pkg-deinstall.in9
-rw-r--r--devel/chora/files/pkg-install.in23
2 files changed, 26 insertions, 6 deletions
diff --git a/devel/chora/files/pkg-deinstall.in b/devel/chora/files/pkg-deinstall.in
index 0ef032fe5654..ca19b4bfa602 100644
--- a/devel/chora/files/pkg-deinstall.in
+++ b/devel/chora/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%CHORADIR%%/config/*php %%CHORADIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/devel/chora/files/pkg-install.in b/devel/chora/files/pkg-install.in
new file mode 100644
index 000000000000..4c605270649a
--- /dev/null
+++ b/devel/chora/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%CHORADIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac