aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-infix-clisp
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 12:46:43 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 12:46:43 +0000
commit0a1dc6564395f2fe98a8fdc2f2957bb96e030b78 (patch)
tree7fa708ff841f01b5d5f81e63c26d4b9bc0fcb766 /devel/cl-infix-clisp
parent4953aac55f2bff1e2da20d8047dc751971f03b34 (diff)
downloadports-0a1dc6564395f2fe98a8fdc2f2957bb96e030b78.tar.gz
ports-0a1dc6564395f2fe98a8fdc2f2957bb96e030b78.zip
Notes
Diffstat (limited to 'devel/cl-infix-clisp')
-rw-r--r--devel/cl-infix-clisp/Makefile26
-rw-r--r--devel/cl-infix-clisp/pkg-descr13
2 files changed, 39 insertions, 0 deletions
diff --git a/devel/cl-infix-clisp/Makefile b/devel/cl-infix-clisp/Makefile
new file mode 100644
index 000000000000..ed0af9a4b044
--- /dev/null
+++ b/devel/cl-infix-clisp/Makefile
@@ -0,0 +1,26 @@
+# New ports collection Makefile for: cl-infix-clisp
+# Date created: 20 Jan 2010
+# Whom: Jimmy Olgeni <olgeni@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= infix
+PORTVERSION= 19960628
+CATEGORIES= devel lisp
+PKGNAMEPREFIX= cl-
+DISTFILES= # none
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A lisp macro to read math statements in infix notation
+
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/infix/infix.asd:${PORTSDIR}/devel/cl-infix
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/infix/infix.asd:${PORTSDIR}/devel/cl-infix
+
+NO_CDROM= No fees or compensation can be charged
+
+USE_ASDF_FASL= yes
+FASL_TARGET= clisp
+FASL_BUILD= yes
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+.include <bsd.port.mk>
diff --git a/devel/cl-infix-clisp/pkg-descr b/devel/cl-infix-clisp/pkg-descr
new file mode 100644
index 000000000000..fa9d4b4b9733
--- /dev/null
+++ b/devel/cl-infix-clisp/pkg-descr
@@ -0,0 +1,13 @@
+This is an implementation of an infix reader macro. It should run in any
+valid Common Lisp and has been tested in Allegro CL 4.1, Lucid CL 4.0.1,
+MCL 2.0 and CMU CL. It allows the user to type arithmetic expressions in
+the traditional way (e.g., 1+2) when writing Lisp programs instead of
+using the normal Lisp syntax (e.g., (+ 1 2)). It is not intended to be a
+full replacement for the normal Lisp syntax.
+
+This package is compiled with CLISP.
+
+Written by Mark Kantrowitz, School of Computer Science,
+Carnegie Mellon University, March 1993.
+
+WWW: http://www.cliki.net/infix