aboutsummaryrefslogtreecommitdiff
path: root/devel/clanlib
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-23 00:20:38 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-23 00:20:38 +0000
commita63b9de3d5dce019de69790499757a3e09d6d7d7 (patch)
treec07c87b490da3704f27cc21fa11fcb42c8bf18dd /devel/clanlib
parentaf28589d8a03bdeb1ea040a906f0d9ade70e5ff3 (diff)
downloadports-a63b9de3d5dce019de69790499757a3e09d6d7d7.tar.gz
ports-a63b9de3d5dce019de69790499757a3e09d6d7d7.zip
Notes
Diffstat (limited to 'devel/clanlib')
-rw-r--r--devel/clanlib/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 6b19c355cbc0..6299c5f4fa95 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -14,15 +14,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-platform game SDK
LICENSE= ZLIB
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- mikmod:${PORTSDIR}/audio/libmikmod \
- vorbis:${PORTSDIR}/audio/libvorbis \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- pcre:${PORTSDIR}/devel/pcre \
- execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libmikmod.so:${PORTSDIR}/audio/libmikmod \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USE_GCC= yes
USE_XORG= x11
@@ -53,7 +52,6 @@ CONFIGURE_ARGS= --disable-docs \
PLIST_SUB+= VER=${PORTVERSION:R} \
SHORT_VER=${PORTVERSION:R:R}${PORTVERSION:R:E}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|LIBS="-lsqlite3 -ldl"|LIBS="-lsqlite3"|g' \
${WRKSRC}/configure
@@ -63,4 +61,5 @@ post-patch:
${WRKSRC}/Sources/Core/System/system.cpp
@${REINPLACE_CMD} -e '47 s|#ifndef __FreeBSD__|#if !defined(__FreeBSD__)|g' \
${WRKSRC}/Sources/Core/System/system.cpp
+
.include <bsd.port.mk>