aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-05 18:34:22 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-05 18:34:22 +0000
commite984a3a1c448241310006307c6865ab24014b7e3 (patch)
treef32ee7b1238a5be5178c342fb367d0842295aaf9 /devel/cmake
parent75802bbff37ed86639abbfae24fe09ec44208234 (diff)
downloadports-e984a3a1c448241310006307c6865ab24014b7e3.tar.gz
ports-e984a3a1c448241310006307c6865ab24014b7e3.zip
Notes
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile2
-rw-r--r--devel/cmake/distinfo4
-rw-r--r--devel/cmake/files/patch-CMakeLists.txt12
-rw-r--r--devel/cmake/files/patch-Modules_FindGTK2.cmake25
-rw-r--r--devel/cmake/files/patch-Modules_FindwxWidgets.cmake8
-rw-r--r--devel/cmake/files/patch-Source__kwsys__SystemInformation.cxx41
6 files changed, 54 insertions, 38 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index 98d0361904d1..b53834909a83 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cmake
-PORTVERSION= 2.8.11.2
+PORTVERSION= 2.8.12
CATEGORIES= devel
MASTER_SITES= http://www.cmake.org/files/v2.8/
diff --git a/devel/cmake/distinfo b/devel/cmake/distinfo
index 6c43aae6c347..bea130ee4db6 100644
--- a/devel/cmake/distinfo
+++ b/devel/cmake/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cmake-2.8.11.2.tar.gz) = b32acb483afdd14339941c6e4ec25f633d916a7a472653a0b00838771a6c0562
-SIZE (cmake-2.8.11.2.tar.gz) = 5887016
+SHA256 (cmake-2.8.12.tar.gz) = d885ba10b2406ede59aa31a928df33c9d67fc01433202f7dd586999cfd0e0287
+SIZE (cmake-2.8.12.tar.gz) = 6064138
diff --git a/devel/cmake/files/patch-CMakeLists.txt b/devel/cmake/files/patch-CMakeLists.txt
index d5b7f23dc8e1..1672fce09de4 100644
--- a/devel/cmake/files/patch-CMakeLists.txt
+++ b/devel/cmake/files/patch-CMakeLists.txt
@@ -1,12 +1,12 @@
---- CMakeLists.txt.orig 2012-11-27 22:20:59.000000000 +0200
-+++ CMakeLists.txt 2012-11-27 22:23:04.000000000 +0200
-@@ -605,17 +605,17 @@
- install(FILES Copyright.txt DESTINATION ${CMake_DOC_DEST})
+--- CMakeLists.txt.orig 2013-10-14 16:29:44.055730052 +0300
++++ CMakeLists.txt 2013-10-14 16:30:05.395729128 +0300
+@@ -629,17 +629,17 @@
+ install(FILES Copyright.txt DESTINATION ${CMAKE_DOC_DIR})
# Install script directories.
-install(
- DIRECTORY Modules Templates
-- DESTINATION "${CMake_DATA_DEST}"
+- DESTINATION ${CMAKE_DATA_DIR}
- FILE_PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
- DIRECTORY_PERMISSIONS OWNER_READ OWNER_EXECUTE OWNER_WRITE
- GROUP_READ GROUP_EXECUTE
@@ -17,7 +17,7 @@
- )
+# install(
+# DIRECTORY Modules Templates
-+# DESTINATION "${CMake_DATA_DEST}"
++# DESTINATION ${CMAKE_DATA_DIR}
+# FILE_PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
+# DIRECTORY_PERMISSIONS OWNER_READ OWNER_EXECUTE OWNER_WRITE
+# GROUP_READ GROUP_EXECUTE
diff --git a/devel/cmake/files/patch-Modules_FindGTK2.cmake b/devel/cmake/files/patch-Modules_FindGTK2.cmake
deleted file mode 100644
index ce343d6d0e57..000000000000
--- a/devel/cmake/files/patch-Modules_FindGTK2.cmake
+++ /dev/null
@@ -1,25 +0,0 @@
-commit 508e8ca024e47baea342da85c7bbd014c7fd6c30
-Author: Daniele E. Domenichelli <ddomenichelli@kde.org>
-Date: Mon Jun 17 17:31:10 2013 +0200
-
- FindGTK2: Detect gthread library
-
-commit 76c72b9f14258933e4cf810da275bd2b931c5ac9
-Author: Daniele E. Domenichelli <daniele.domenichelli@iit.it>
-Date: Wed Jul 31 17:39:38 2013 +0200
-
- FindGTK2: gthread-2.0 folder does not exist
-
- Partially revert commit 508e8ca024e47baea342da85c7bbd014c7fd6c30
-
---- Modules/FindGTK2.cmake.orig 2013-09-29 17:29:09.000000000 +0300
-+++ Modules/FindGTK2.cmake 2013-09-29 17:29:42.000000000 +0300
-@@ -463,6 +463,8 @@
- _GTK2_FIND_INCLUDE_DIR(GTK2_GDK_PIXBUF_INCLUDE_DIR gdk-pixbuf/gdk-pixbuf.h)
- _GTK2_FIND_LIBRARY (GTK2_GDK_PIXBUF_LIBRARY gdk_pixbuf false true)
-
-+ _GTK2_FIND_LIBRARY (GTK2_GTHREAD_LIBRARY gthread false true)
-+
- _GTK2_FIND_LIBRARY (GTK2_GIO_LIBRARY gio false true)
-
- _GTK2_FIND_INCLUDE_DIR(GTK2_ATK_INCLUDE_DIR atk/atk.h)
diff --git a/devel/cmake/files/patch-Modules_FindwxWidgets.cmake b/devel/cmake/files/patch-Modules_FindwxWidgets.cmake
index 47ee294e1590..01c7b5f07c17 100644
--- a/devel/cmake/files/patch-Modules_FindwxWidgets.cmake
+++ b/devel/cmake/files/patch-Modules_FindwxWidgets.cmake
@@ -1,11 +1,11 @@
---- ./Modules/FindwxWidgets.cmake.orig 2010-06-28 19:15:57.000000000 +0400
-+++ ./Modules/FindwxWidgets.cmake 2010-07-06 02:06:02.277945209 +0400
-@@ -689,7 +689,7 @@
+--- Modules/FindwxWidgets.cmake.orig 2013-10-14 16:39:11.995705456 +0300
++++ Modules/FindwxWidgets.cmake 2013-10-14 16:39:31.315704621 +0300
+@@ -702,7 +702,7 @@
# UNIX: Start actual work.
#-----------------------------------------------------------------
# Support cross-compiling, only search in the target platform.
- find_program(wxWidgets_CONFIG_EXECUTABLE wx-config
+ find_program(wxWidgets_CONFIG_EXECUTABLE NAMES $ENV{WX_CONFIG} wx-config
+ DOC "Location of wxWidgets library configuration provider binary (wx-config)."
ONLY_CMAKE_FIND_ROOT_PATH
)
-
diff --git a/devel/cmake/files/patch-Source__kwsys__SystemInformation.cxx b/devel/cmake/files/patch-Source__kwsys__SystemInformation.cxx
new file mode 100644
index 000000000000..8cb8ecb9a9cd
--- /dev/null
+++ b/devel/cmake/files/patch-Source__kwsys__SystemInformation.cxx
@@ -0,0 +1,41 @@
+From e0b5a0523e6ba75efc97d5fc0bc5299b5f3d3bca Mon Sep 17 00:00:00 2001
+From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon, 14 Oct 2013 23:35:05 +0300
+Subject: [PATCH] KWSys: Include backtrace-related headers on FreeBSD.
+
+This was probably broken for a long while, but the problem was not apparent
+because the check for execinfo.h would fail by default because
+-I/usr/local/include was not being passed to the compiler when making the
+checks for the header's existence.
+
+Now that very recent FreeBSD versions (ie. 10-CURRENT) have NetBSD's
+libexecinfo in base (and it is thus installed into /usr), the
+backtrace-related checks would pass, but the required headers were not being
+included in SystemInformation.cxx.
+---
+ Source/kwsys/SystemInformation.cxx | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation.cxx
+index 7c31f3a..2672730 100644
+--- Source/kwsys/SystemInformation.cxx
++++ Source/kwsys/SystemInformation.cxx
+@@ -88,6 +88,15 @@ typedef int siginfo_t;
+ # include <ifaddrs.h>
+ # define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
+ # endif
++# if defined(KWSYS_SYSTEMINFORMATION_HAS_BACKTRACE)
++# include <execinfo.h>
++# if defined(KWSYS_SYSTEMINFORMATION_HAS_CPP_DEMANGLE)
++# include <cxxabi.h>
++# endif
++# if defined(KWSYS_SYSTEMINFORMATION_HAS_SYMBOL_LOOKUP)
++# include <dlfcn.h>
++# endif
++# endif
+ #endif
+
+ #if defined(__OpenBSD__) || defined(__NetBSD__)
+--
+1.8.4
+