aboutsummaryrefslogtreecommitdiff
path: root/devel/codeblocks
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-09-30 16:03:23 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-09-30 16:03:23 +0000
commit586255bfed63021019208bebdb8c861c9784148a (patch)
tree590613f1d5a7d8ec0ed20a5c48ca3422daa9c514 /devel/codeblocks
parentad285a123b8b873f1d40d363878e153aa35c4ab2 (diff)
downloadports-586255bfed63021019208bebdb8c861c9784148a.tar.gz
ports-586255bfed63021019208bebdb8c861c9784148a.zip
Catch stray dependencies, courtesy of the proxy-deps qa check.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=422995
Diffstat (limited to 'devel/codeblocks')
-rw-r--r--devel/codeblocks/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 4117bc323a69..8cc23ce7b3a0 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -3,6 +3,7 @@
PORTNAME= codeblocks
PORTVERSION= 16.01
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -15,12 +16,15 @@ LICENSE_COMB= multi
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libhunspell-1.3.so:textproc/hunspell
-USES= autoreconf compiler desktop-file-utils fam:gamin libtool pathfix \
- pkgconfig shared-mime-info
+USES= autoreconf compiler desktop-file-utils fam:gamin \
+ gettext-runtime libtool pathfix pkgconfig shared-mime-info
USE_WX= 2.8
-WANT_UNICODE= yes
+USE_GNOME= gtk20 cairo
+USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG} --with-contrib-plugins=all \
--disable-pch