aboutsummaryrefslogtreecommitdiff
path: root/devel/codeblocks
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-01-07 09:00:36 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-01-07 09:00:36 +0000
commitad402a8f786e8592b5930f79790fb38df95f781f (patch)
tree84627935c57e873ed8fdc51d9c1e0bad17db5bea /devel/codeblocks
parentbac0009e7791e3696bd502c3b7decde7ba9d5606 (diff)
downloadports-ad402a8f786e8592b5930f79790fb38df95f781f.tar.gz
ports-ad402a8f786e8592b5930f79790fb38df95f781f.zip
Update to upstream release 17.12
Details: - New release 17.12, changelog on http://www.codeblocks.org/downloads/binaries/changelog - This includes fixes for stability of the application which should allow to close bug #223826 and bug #197888 PR: 224835 Submitted by: lbartoletti@tuxfamily.org (maintainer) MFH: 2018Q1
Notes
Notes: svn path=/head/; revision=458306
Diffstat (limited to 'devel/codeblocks')
-rw-r--r--devel/codeblocks/Makefile12
-rw-r--r--devel/codeblocks/distinfo5
-rw-r--r--devel/codeblocks/files/patch-src_sdk_scripting_squirrel_sqvm.cpp12
-rw-r--r--devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp11
-rw-r--r--devel/codeblocks/pkg-plist86
5 files changed, 98 insertions, 28 deletions
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 849e88928b66..7e232c043fa5 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= codeblocks
-PORTVERSION= 16.01
-PORTREVISION= 8
+PORTVERSION= 17.12
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -18,22 +17,23 @@ BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libhunspell-1.6.so:textproc/hunspell
+ libhunspell-1.6.so:textproc/hunspell \
+ libtinyxml.so:textproc/tinyxml
-USES= autoreconf compiler desktop-file-utils fam:gamin localbase \
+USES= tar:xz autoreconf compiler desktop-file-utils fam:gamin localbase \
gettext-runtime libtool pathfix pkgconfig shared-mime-info
USE_WX= 2.8
USE_GNOME= gtk20 cairo
USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG} --with-contrib-plugins=all \
- --disable-pch
+ --disable-pch --with-boost-system=boost_system
PKG_CONFIG_LIBDIR= ${LOCALBASE}/libdata/pkgconfig
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.release
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
diff --git a/devel/codeblocks/distinfo b/devel/codeblocks/distinfo
index 1115da64ebec..5116b4a820e8 100644
--- a/devel/codeblocks/distinfo
+++ b/devel/codeblocks/distinfo
@@ -1,2 +1,3 @@
-SHA256 (codeblocks_16.01.tar.gz) = 30fb9d206df4ab3c2e2fec2451a0a7c9723bfed9a673cc9be71e881c529d5a03
-SIZE (codeblocks_16.01.tar.gz) = 20250097
+TIMESTAMP = 1514861811
+SHA256 (codeblocks_17.12.tar.xz) = 13881a0a72769694e82e531b8e7814d51fbf1fa122c73c5004e186560fbc57e0
+SIZE (codeblocks_17.12.tar.xz) = 15725976
diff --git a/devel/codeblocks/files/patch-src_sdk_scripting_squirrel_sqvm.cpp b/devel/codeblocks/files/patch-src_sdk_scripting_squirrel_sqvm.cpp
new file mode 100644
index 000000000000..48e1d2f16030
--- /dev/null
+++ b/devel/codeblocks/files/patch-src_sdk_scripting_squirrel_sqvm.cpp
@@ -0,0 +1,12 @@
+--- src/sdk/scripting/squirrel/sqvm.cpp.orig 2017-10-31 23:32:38 UTC
++++ src/sdk/scripting/squirrel/sqvm.cpp
+@@ -1,8 +1,8 @@
+ /*
+ see copyright notice in squirrel.h
+ */
+-#include "sqpcheader.h"
+ #include <math.h>
++#include "sqpcheader.h"
+ #include <stdlib.h>
+ #include "sqopcodes.h"
+ #include "sqfuncproto.h"
diff --git a/devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp b/devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp
deleted file mode 100644
index f477e36226c6..000000000000
--- a/devel/codeblocks/files/patch-src_sdk_wxscintilla_src_ScintillaWX.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/sdk/wxscintilla/src/ScintillaWX.cpp.orig 2016-01-23 16:43:01 UTC
-+++ src/sdk/wxscintilla/src/ScintillaWX.cpp
-@@ -290,7 +290,7 @@ static int wxCountLines(const char* text
-
- /* C::B begin */
- // Constant ids for the timers used by every editor.
--const int timerIDs[ScintillaWX::timersCount] = { wxNewId(), wxNewId(), wxNewId(), wxNewId() };
-+const int timerIDs[ScintillaWX::timersCount] = { static_cast<int>(wxNewId()), static_cast<int>(wxNewId()), static_cast<int>(wxNewId()), static_cast<int>(wxNewId()) };
- /* C::B end */
-
- //----------------------------------------------------------------------
diff --git a/devel/codeblocks/pkg-plist b/devel/codeblocks/pkg-plist
index 7685d854dfa6..ab76ace1b154 100644
--- a/devel/codeblocks/pkg-plist
+++ b/devel/codeblocks/pkg-plist
@@ -71,14 +71,13 @@ include/codeblocks/ibaseloader.h
include/codeblocks/ibaseworkspaceloader.h
include/codeblocks/id.h
include/codeblocks/importers_globals.h
-include/codeblocks/incrementalselectlistdlg.h
+include/codeblocks/incremental_select_helper.h
include/codeblocks/infowindow.h
include/codeblocks/licenses.h
include/codeblocks/logger.h
include/codeblocks/loggers.h
include/codeblocks/logmanager.h
include/codeblocks/macrosmanager.h
-include/codeblocks/managedthread.h
include/codeblocks/manager.h
include/codeblocks/menuitemsmanager.h
include/codeblocks/misctreeitemdata.h
@@ -156,8 +155,8 @@ include/codeblocks/searchresultslog.h
include/codeblocks/selecttargetdlg.h
include/codeblocks/settings.h
include/codeblocks/templatemanager.h
+include/codeblocks/tinywxuni.h
include/codeblocks/tinyxml/tinystr.h
-include/codeblocks/tinyxml/tinywxuni.h
include/codeblocks/tinyxml/tinyxml.h
include/codeblocks/toolsmanager.h
include/codeblocks/uservarmanager.h
@@ -324,6 +323,7 @@ include/wxsmith/wxwidgets/wxwidgetsguiappadoptingdlg.h
include/wxsmith/wxwidgets/wxwidgetsguiconfigpanel.h
include/wxsmith/wxwidgets/wxwidgetsres.h
include/wxsmith/wxwidgets/wxwidgetsresfactory.h
+lib/codeblocks/plugins/libAstyle.so
lib/codeblocks/plugins/libAutoVersioning.so
lib/codeblocks/plugins/libBrowseTracker.so
lib/codeblocks/plugins/libCccc.so
@@ -354,7 +354,6 @@ lib/codeblocks/plugins/libThreadSearch.so
lib/codeblocks/plugins/libToolsPlus.so
lib/codeblocks/plugins/libValgrind.so
lib/codeblocks/plugins/libabbreviations.so
-lib/codeblocks/plugins/libastyle.so
lib/codeblocks/plugins/libautosave.so
lib/codeblocks/plugins/libbyogames.so
lib/codeblocks/plugins/libcb_koders.so
@@ -414,7 +413,6 @@ lib/libcodeblocks.so.0.0.1
lib/libwxsmithlib.so
lib/libwxsmithlib.so.0
lib/libwxsmithlib.so.0.0.1
-libdata/pkgconfig/codeblocks.pc
libdata/pkgconfig/cb_wxKWIC.pc
libdata/pkgconfig/cb_wxchartctrl.pc
libdata/pkgconfig/cb_wxcontrib.pc
@@ -425,6 +423,7 @@ libdata/pkgconfig/cb_wxled.pc
libdata/pkgconfig/cb_wxmathplot.pc
libdata/pkgconfig/cb_wxspeedbutton.pc
libdata/pkgconfig/cb_wxtreelist.pc
+libdata/pkgconfig/codeblocks.pc
libdata/pkgconfig/wxsmith-contrib.pc
libdata/pkgconfig/wxsmith.pc
libdata/pkgconfig/wxsmithaui.pc
@@ -432,7 +431,10 @@ man/man1/cb_console_runner.1.gz
man/man1/cb_share_config.1.gz
man/man1/codeblocks.1.gz
man/man1/codesnippets.1.gz
+share/appdata/codeblocks-contrib.metainfo.xml
+share/appdata/codeblocks.appdata.xml
share/applications/codeblocks.desktop
+%%DATADIR%%/Astyle.zip
%%DATADIR%%/AutoVersioning.zip
%%DATADIR%%/BrowseTracker.zip
%%DATADIR%%/Cccc.zip
@@ -475,7 +477,6 @@ share/applications/codeblocks.desktop
%%DATADIR%%/ToolsPlus.zip
%%DATADIR%%/Valgrind.zip
%%DATADIR%%/abbreviations.zip
-%%DATADIR%%/astyle.zip
%%DATADIR%%/autosave.zip
%%DATADIR%%/byogames.zip
%%DATADIR%%/cb_koders.zip
@@ -484,6 +485,7 @@ share/applications/codeblocks.desktop
%%DATADIR%%/codesnippets.zip
%%DATADIR%%/codestat.zip
%%DATADIR%%/compiler.zip
+%%DATADIR%%/compilers/compiler_android-gcc.xml
%%DATADIR%%/compilers/compiler_avr-gcc.xml
%%DATADIR%%/compilers/compiler_bcc.xml
%%DATADIR%%/compilers/compiler_bfin-elf-gcc.xml
@@ -494,13 +496,16 @@ share/applications/codeblocks.desktop
%%DATADIR%%/compilers/compiler_lm32-gcc.xml
%%DATADIR%%/compilers/compiler_lm8-gcc.xml
%%DATADIR%%/compilers/compiler_msp430-gcc.xml
+%%DATADIR%%/compilers/compiler_mw.xml
%%DATADIR%%/compilers/compiler_null.xml
%%DATADIR%%/compilers/compiler_pgifortran.xml
+%%DATADIR%%/compilers/compiler_powerpc-eabi.xml
%%DATADIR%%/compilers/compiler_ppc-gcc.xml
%%DATADIR%%/compilers/compiler_sdcc.xml
%%DATADIR%%/compilers/compiler_tcc.xml
%%DATADIR%%/compilers/compiler_tricore-gcc.xml
%%DATADIR%%/compilers/compiler_zpu-gcc.xml
+%%DATADIR%%/compilers/options_android-gcc.xml
%%DATADIR%%/compilers/options_arm-elf-gcc.xml
%%DATADIR%%/compilers/options_avr-gcc.xml
%%DATADIR%%/compilers/options_bcc.xml
@@ -539,9 +544,11 @@ share/applications/codeblocks.desktop
%%DATADIR%%/compilers/options_msvc10.xml
%%DATADIR%%/compilers/options_msvc8.xml
%%DATADIR%%/compilers/options_msvctk.xml
+%%DATADIR%%/compilers/options_mw.xml
%%DATADIR%%/compilers/options_null.xml
%%DATADIR%%/compilers/options_ow.xml
%%DATADIR%%/compilers/options_pgifortran.xml
+%%DATADIR%%/compilers/options_powerpc-eabi.xml
%%DATADIR%%/compilers/options_ppc-gcc.xml
%%DATADIR%%/compilers/options_sdcc.xml
%%DATADIR%%/compilers/options_tcc.xml
@@ -1150,6 +1157,8 @@ share/applications/codeblocks.desktop
%%DATADIR%%/lexers/lexer_ada.xml
%%DATADIR%%/lexers/lexer_angelscript.sample
%%DATADIR%%/lexers/lexer_angelscript.xml
+%%DATADIR%%/lexers/lexer_autotools.sample
+%%DATADIR%%/lexers/lexer_autotools.xml
%%DATADIR%%/lexers/lexer_bash.sample
%%DATADIR%%/lexers/lexer_bash.xml
%%DATADIR%%/lexers/lexer_batch.sample
@@ -1168,6 +1177,8 @@ share/applications/codeblocks.desktop
%%DATADIR%%/lexers/lexer_cpp.xml
%%DATADIR%%/lexers/lexer_css.sample
%%DATADIR%%/lexers/lexer_css.xml
+%%DATADIR%%/lexers/lexer_cu.sample
+%%DATADIR%%/lexers/lexer_cu.xml
%%DATADIR%%/lexers/lexer_d.sample
%%DATADIR%%/lexers/lexer_d.xml
%%DATADIR%%/lexers/lexer_diff.sample
@@ -1188,6 +1199,8 @@ share/applications/codeblocks.desktop
%%DATADIR%%/lexers/lexer_html.xml
%%DATADIR%%/lexers/lexer_ihex.sample
%%DATADIR%%/lexers/lexer_ihex.xml
+%%DATADIR%%/lexers/lexer_inno.sample
+%%DATADIR%%/lexers/lexer_inno.xml
%%DATADIR%%/lexers/lexer_java.sample
%%DATADIR%%/lexers/lexer_java.xml
%%DATADIR%%/lexers/lexer_javascript.sample
@@ -1214,6 +1227,8 @@ share/applications/codeblocks.desktop
%%DATADIR%%/lexers/lexer_perl.xml
%%DATADIR%%/lexers/lexer_postscript.sample
%%DATADIR%%/lexers/lexer_postscript.xml
+%%DATADIR%%/lexers/lexer_powershell.sample
+%%DATADIR%%/lexers/lexer_powershell.xml
%%DATADIR%%/lexers/lexer_prg.sample
%%DATADIR%%/lexers/lexer_prg.xml
%%DATADIR%%/lexers/lexer_properties.sample
@@ -1261,7 +1276,6 @@ share/applications/codeblocks.desktop
%%DATADIR%%/scripts/plugin_find_broken_files.script
%%DATADIR%%/scripts/sample_plugin.script
%%DATADIR%%/scripts/startup.script
-%%DATADIR%%/scripts/stl-views-1.0.3.gdb
%%DATADIR%%/scripts/tests/menu_test_plugin.script
%%DATADIR%%/scripts/tests/script_test_plugin.script
%%DATADIR%%/scripts/tests/test_base.script
@@ -1300,6 +1314,10 @@ share/applications/codeblocks.desktop
%%DATADIR%%/templates/sdl-cb.bmp
%%DATADIR%%/templates/sdl-main.cpp
%%DATADIR%%/templates/sdl.png
+%%DATADIR%%/templates/sdl2-main.cpp
+%%DATADIR%%/templates/sdl2.png
+%%DATADIR%%/templates/sdl2app.cbp
+%%DATADIR%%/templates/sdl2app.template
%%DATADIR%%/templates/sdlapp.cbp
%%DATADIR%%/templates/sdlapp.template
%%DATADIR%%/templates/sfml-cb.bmp
@@ -1313,6 +1331,29 @@ share/applications/codeblocks.desktop
%%DATADIR%%/templates/staticlib-sample.c
%%DATADIR%%/templates/staticlib.cbp
%%DATADIR%%/templates/staticlib.template
+%%DATADIR%%/templates/wizard/arduino/files/cores/CDC.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/HID.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/HardwareSerial.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/IPAddress.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/Print.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/Stream.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/Tone.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/USBCore.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/WInterrupts.c
+%%DATADIR%%/templates/wizard/arduino/files/cores/WMath.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/WString.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/libraries.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/main.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/new.cpp
+%%DATADIR%%/templates/wizard/arduino/files/cores/wiring.c
+%%DATADIR%%/templates/wizard/arduino/files/cores/wiring_analog.c
+%%DATADIR%%/templates/wizard/arduino/files/cores/wiring_digital.c
+%%DATADIR%%/templates/wizard/arduino/files/cores/wiring_pulse.c
+%%DATADIR%%/templates/wizard/arduino/files/cores/wiring_shift.c
+%%DATADIR%%/templates/wizard/arduino/files/sketch.cpp
+%%DATADIR%%/templates/wizard/arduino/logo.png
+%%DATADIR%%/templates/wizard/arduino/wizard.png
+%%DATADIR%%/templates/wizard/arduino/wizard.script
%%DATADIR%%/templates/wizard/arm/files/ARM-eval7t/h/evaluator7t.h
%%DATADIR%%/templates/wizard/arm/files/ARM-eval7t/ld/target.ld
%%DATADIR%%/templates/wizard/arm/files/ARM-eval7t/src/main.c
@@ -1392,6 +1433,9 @@ share/applications/codeblocks.desktop
%%DATADIR%%/templates/wizard/d/logo.png
%%DATADIR%%/templates/wizard/d/wizard.png
%%DATADIR%%/templates/wizard/d/wizard.script
+%%DATADIR%%/templates/wizard/d_source/logo.png
+%%DATADIR%%/templates/wizard/d_source/wizard.png
+%%DATADIR%%/templates/wizard/d_source/wizard.script
%%DATADIR%%/templates/wizard/directx/dx8/main.cpp
%%DATADIR%%/templates/wizard/directx/dx9/main.cpp
%%DATADIR%%/templates/wizard/directx/logo.png
@@ -1449,6 +1493,13 @@ share/applications/codeblocks.desktop
%%DATADIR%%/templates/wizard/irrlicht/logo.png
%%DATADIR%%/templates/wizard/irrlicht/wizard.png
%%DATADIR%%/templates/wizard/irrlicht/wizard.script
+%%DATADIR%%/templates/wizard/java/file/logo.png
+%%DATADIR%%/templates/wizard/java/file/wizard.png
+%%DATADIR%%/templates/wizard/java/file/wizard.script
+%%DATADIR%%/templates/wizard/java/files/Main.java
+%%DATADIR%%/templates/wizard/java/logo.png
+%%DATADIR%%/templates/wizard/java/wizard.png
+%%DATADIR%%/templates/wizard/java/wizard.script
%%DATADIR%%/templates/wizard/lf/files/quick/main.cpp
%%DATADIR%%/templates/wizard/lf/files/structured/CMain.cpp
%%DATADIR%%/templates/wizard/lf/files/structured/CMain.h
@@ -1457,9 +1508,9 @@ share/applications/codeblocks.desktop
%%DATADIR%%/templates/wizard/lf/wizard.png
%%DATADIR%%/templates/wizard/lf/wizard.script
%%DATADIR%%/templates/wizard/lf/wizard.xrc
-%%DATADIR%%/templates/wizard/matlab_csf/files/lccstub.c
%%DATADIR%%/templates/wizard/matlab_csf/files/mexversion.rc
%%DATADIR%%/templates/wizard/matlab_csf/files/sfuntmpl.c
+%%DATADIR%%/templates/wizard/matlab_csf/lccstub/lccstub.c
%%DATADIR%%/templates/wizard/matlab_csf/logo.png
%%DATADIR%%/templates/wizard/matlab_csf/wizard.png
%%DATADIR%%/templates/wizard/matlab_csf/wizard.script
@@ -1469,11 +1520,16 @@ share/applications/codeblocks.desktop
%%DATADIR%%/templates/wizard/mcs51/wizard.png
%%DATADIR%%/templates/wizard/mcs51/wizard.script
%%DATADIR%%/templates/wizard/mcs51/wizard.xrc
+%%DATADIR%%/templates/wizard/msp430/files/main.c
+%%DATADIR%%/templates/wizard/msp430/logo.png
+%%DATADIR%%/templates/wizard/msp430/wizard.png
+%%DATADIR%%/templates/wizard/msp430/wizard.script
+%%DATADIR%%/templates/wizard/msp430/wizard.xrc
%%DATADIR%%/templates/wizard/ogre/files/main.cpp
%%DATADIR%%/templates/wizard/ogre/logo.png
%%DATADIR%%/templates/wizard/ogre/wizard.png
%%DATADIR%%/templates/wizard/ogre/wizard.script
-%%DATADIR%%/templates/wizard/opencv/files/lena.jpg
+%%DATADIR%%/templates/wizard/opencv/files/arnold_schwarzenegger.jpg
%%DATADIR%%/templates/wizard/opencv/files/main.cpp
%%DATADIR%%/templates/wizard/opencv/logo.png
%%DATADIR%%/templates/wizard/opencv/wizard.png
@@ -1513,11 +1569,23 @@ share/applications/codeblocks.desktop
%%DATADIR%%/templates/wizard/qt4/logo.png
%%DATADIR%%/templates/wizard/qt4/wizard.png
%%DATADIR%%/templates/wizard/qt4/wizard.script
+%%DATADIR%%/templates/wizard/qt4dll/files/main.cpp
+%%DATADIR%%/templates/wizard/qt4dll/logo.png
+%%DATADIR%%/templates/wizard/qt4dll/wizard.png
+%%DATADIR%%/templates/wizard/qt4dll/wizard.script
+%%DATADIR%%/templates/wizard/qt5/files/main.cpp
+%%DATADIR%%/templates/wizard/qt5/logo.png
+%%DATADIR%%/templates/wizard/qt5/wizard.png
+%%DATADIR%%/templates/wizard/qt5/wizard.script
%%DATADIR%%/templates/wizard/sdl/files/cb.bmp
%%DATADIR%%/templates/wizard/sdl/files/main.cpp
%%DATADIR%%/templates/wizard/sdl/logo.png
%%DATADIR%%/templates/wizard/sdl/wizard.png
%%DATADIR%%/templates/wizard/sdl/wizard.script
+%%DATADIR%%/templates/wizard/sdl2/files/main.cpp
+%%DATADIR%%/templates/wizard/sdl2/logo.png
+%%DATADIR%%/templates/wizard/sdl2/wizard.png
+%%DATADIR%%/templates/wizard/sdl2/wizard.script
%%DATADIR%%/templates/wizard/sfml/logo.png
%%DATADIR%%/templates/wizard/sfml/sfml1/cb.bmp
%%DATADIR%%/templates/wizard/sfml/sfml1/main.cpp