aboutsummaryrefslogtreecommitdiff
path: root/devel/colorgcc
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2009-07-21 13:47:09 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2009-07-21 13:47:09 +0000
commit7ee0ace4630e95e1028d2fea5234d1eb11634719 (patch)
treeb62345580933b343d899ba3261484d9303ccaa5b /devel/colorgcc
parent5fa2f8743f450f265bc93114b385ed6a93213a55 (diff)
downloadports-7ee0ace4630e95e1028d2fea5234d1eb11634719.tar.gz
ports-7ee0ace4630e95e1028d2fea5234d1eb11634719.zip
Notes
Diffstat (limited to 'devel/colorgcc')
-rw-r--r--devel/colorgcc/Makefile43
-rw-r--r--devel/colorgcc/distinfo3
-rw-r--r--devel/colorgcc/files/colorgccrc54
-rw-r--r--devel/colorgcc/files/pkg-message.in7
-rw-r--r--devel/colorgcc/pkg-descr4
5 files changed, 111 insertions, 0 deletions
diff --git a/devel/colorgcc/Makefile b/devel/colorgcc/Makefile
new file mode 100644
index 000000000000..732d831c546f
--- /dev/null
+++ b/devel/colorgcc/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: colorgcc
+# Date created: 2009-07-21
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= colorgcc
+PORTVERSION= 1.3.2
+CATEGORIES= devel misc
+MASTER_SITES= http://schlueters.de/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+EXTRACT_SUFX= .txt
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= Perl script to colorize the terminal ouput of GCC
+
+RUN_DEPENDS= ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/examples/${PORTNAME}/${PORTNAME}rc
+PLIST_DIRS= share/examples/${PORTNAME}
+SUB_FILES= pkg-message
+
+NO_BUILD=yes
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_DATA} ${FILESDIR}/${PORTNAME}rc ${EXAMPLESDIR}/
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/colorgcc/distinfo b/devel/colorgcc/distinfo
new file mode 100644
index 000000000000..ff50b24268b4
--- /dev/null
+++ b/devel/colorgcc/distinfo
@@ -0,0 +1,3 @@
+MD5 (colorgcc/colorgcc.1.3.2.txt) = c7d27acb765a283a98db53216edd36d1
+SHA256 (colorgcc/colorgcc.1.3.2.txt) = e27000ed289e8e935ab00b97d7912d3a7a92522bf001d767b432489790035325
+SIZE (colorgcc/colorgcc.1.3.2.txt) = 6688
diff --git a/devel/colorgcc/files/colorgccrc b/devel/colorgcc/files/colorgccrc
new file mode 100644
index 000000000000..5ec5949b7e44
--- /dev/null
+++ b/devel/colorgcc/files/colorgccrc
@@ -0,0 +1,54 @@
+#
+# colorgcc configuration file
+#
+# $Id: colorgccrc,v 1.1.1.1 1999/04/25 15:24:03 jamoyers Exp $
+#
+# This file should be named $HOME/.colorgccrc
+#
+#
+# The following groups of attributes may be combined for a given color:
+#
+# clear black on_black
+# reset red on_red
+# bold green on_green
+# underline yellow on_yellow
+# underscore blue on_blue
+# blink magenta on_magenta
+# reverse cyan on_cyan
+# concealed white on_white
+#
+# For example, srcColor: bold cyan on_yellow
+#
+
+# Define the paths to the actual location of the various compilers.
+# (Currently, colorgcc only understands these: g++ gcc c++ cc)
+g++: /usr/bin/g++
+gcc: /usr/bin/gcc
+c++: /usr/bin/c++
+cc: /usr/bin/cc
+
+# Don't do color if our terminal type ($TERM) is one of these.
+# (List all terminal types on one line, seperated by whitespace.)
+nocolor: dumb
+
+# Text between ` and ' is usually source code.
+srcColor: bold cyan
+
+# Text other than a warning or error.
+introColor: reset
+
+# Warnings and errors both have similar formats:
+# filename:999:Message
+# Each field may be assigned a different color.
+
+# Warnings
+warningFileNameColor: reset
+warningNumberColor: white
+warningMessageColor: yellow
+
+# Errors
+errorFileNameColor: reset
+errorNumberColor: white
+errorMessageColor: bold red
+
+
diff --git a/devel/colorgcc/files/pkg-message.in b/devel/colorgcc/files/pkg-message.in
new file mode 100644
index 000000000000..bde9042c061e
--- /dev/null
+++ b/devel/colorgcc/files/pkg-message.in
@@ -0,0 +1,7 @@
+-------------------------------------------------------------
+colorgcc is installed.
+
+For a quick start:
+ - cp ${EXAMPLESDIR}/colorgccrc ${HOME}/.colorgcc
+ - export CC=${PREFIX}/bin/colorgcc
+-------------------------------------------------------------
diff --git a/devel/colorgcc/pkg-descr b/devel/colorgcc/pkg-descr
new file mode 100644
index 000000000000..c198b1172a75
--- /dev/null
+++ b/devel/colorgcc/pkg-descr
@@ -0,0 +1,4 @@
+colorgcc is a Perl script written by Jamie Moyers to colorize the terminal
+output of GCC so error messages can be found within longer compiler outputs.
+
+WWW: http://schlueters.de/colorgcc.html