aboutsummaryrefslogtreecommitdiff
path: root/devel/cppcheck/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-04-13 00:52:15 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-04-13 00:52:15 +0000
commit0c143bc8f582da8f3cc0b2b0d5acdc70136bc804 (patch)
treee936580c61d13fa34e16e54bdd4b826c3ae50da1 /devel/cppcheck/Makefile
parent5dbdf5eb3a6fc39fe4d17d512fa8e913b51881c0 (diff)
Update to 1.48, add LICENSE
Notes
Notes: svn path=/head/; revision=272652
Diffstat (limited to 'devel/cppcheck/Makefile')
-rw-r--r--devel/cppcheck/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
index 2414200967c8..0d503863c455 100644
--- a/devel/cppcheck/Makefile
+++ b/devel/cppcheck/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cppcheck
-PORTVERSION= 1.47
+PORTVERSION= 1.48
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
@@ -15,6 +15,8 @@ COMMENT= Static analysis of C/C++ code
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+LICENSE= GPLv3
+
USE_GMAKE= yes
USE_BZIP2= yes
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
@@ -44,7 +46,7 @@ post-patch:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/cppcheck ${PREFIX}/bin
-regression-test: build
+check regression-test test: build
@(cd ${BUILD_WRKSRC}; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} test)