aboutsummaryrefslogtreecommitdiff
path: root/devel/critcl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2020-04-29 08:49:04 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2020-04-29 08:49:04 +0000
commit9fa0630ad7bf55e60bf92f0cc98eb091189b945a (patch)
treeffc97b5f7833d049e98ed363f9e2937e289a174d /devel/critcl/Makefile
parent2de2c6e3ea0e58f9094a53a0f2ccfb436118cebc (diff)
downloadports-9fa0630ad7bf55e60bf92f0cc98eb091189b945a.tar.gz
ports-9fa0630ad7bf55e60bf92f0cc98eb091189b945a.zip
Notes
Diffstat (limited to 'devel/critcl/Makefile')
-rw-r--r--devel/critcl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/critcl/Makefile b/devel/critcl/Makefile
index 63f1605b74b3..cf93bfbb2388 100644
--- a/devel/critcl/Makefile
+++ b/devel/critcl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= critcl
PORTVERSION= 3.1.18.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= tcltk@FreeBSD.org
@@ -21,6 +21,7 @@ USES+= tcl
USE_GITHUB= yes
GH_ACCOUNT= andreas-kupries
+MAKE_ENV= CRITCL_HOME=${WRKDIR}
TEST_TARGET= test
PLIST_SUB+= VER=${PORTVERSION:R} \
@@ -36,7 +37,7 @@ post-patch:
${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' ${WRKSRC}/lib/critcl/Config
do-install:
- (cd ${WRKSRC} && ${TCLSH} build.tcl install ${STAGEDIR}${PREFIX}/lib)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${TCLSH} build.tcl install ${STAGEDIR}${PREFIX}/lib)
${INSTALL_MAN} ${WRKSRC}/embedded/man/files/critcl_*.n \
${STAGEDIR}${MANPREFIX}/man/mann/