aboutsummaryrefslogtreecommitdiff
path: root/devel/critcl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-01-07 10:14:44 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-01-07 10:14:44 +0000
commitdcfac1d4123c2f00eb0a335310aa1cb7f223d537 (patch)
tree4cd89b1bc8e51c366c4e9b7676798916fbdd75a0 /devel/critcl/Makefile
parentedd6461233269bb5483f8fa414811b62d6b9bcff (diff)
downloadports-dcfac1d4123c2f00eb0a335310aa1cb7f223d537.tar.gz
ports-dcfac1d4123c2f00eb0a335310aa1cb7f223d537.zip
Notes
Diffstat (limited to 'devel/critcl/Makefile')
-rw-r--r--devel/critcl/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/devel/critcl/Makefile b/devel/critcl/Makefile
index e8656cbcc6fb..c85ff44f7511 100644
--- a/devel/critcl/Makefile
+++ b/devel/critcl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= critcl
-PORTVERSION= 3.1.12
-PORTREVISION= 3
+PORTVERSION= 3.1.15
CATEGORIES= devel
MAINTAINER= tcltk@FreeBSD.org
@@ -17,10 +16,12 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${LOCALBASE}/lib/Trf/pkgIndex.tcl:${PORTSDIR}/devel/tcl-trf \
${LOCALBASE}/lib/tcllib/cmdline/pkgIndex.tcl:${PORTSDIR}/devel/tcllib
-USES+= tcl
+USES+= tcl:85+
USE_GITHUB= yes
GH_ACCOUNT= andreas-kupries
+TEST_TARGET= test
+
PLIST_SUB+= VER=${PORTVERSION}
PORTDOCS= *
@@ -31,13 +32,14 @@ NO_BUILD= yes
post-patch:
${REINPLACE_CMD} -e 's|dtplite|${LOCALBASE}/bin/dtplite|g' ${WRKSRC}/build.tcl
${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' ${WRKSRC}/lib/critcl/Config
+ ${REINPLACE_CMD} -e '/^#line/d' ${WRKSRC}/test/cconst/*
do-install:
(cd ${WRKSRC} && ${TCLSH} build.tcl install ${STAGEDIR}${PREFIX}/lib)
${INSTALL_MAN} ${WRKSRC}/embedded/man/files/critcl_*.n \
${STAGEDIR}${MANPREFIX}/man/mann/
-test check regression-test: build
+test: build
(cd ${WRKSRC} && ${TCLSH} test/all.tcl)
.include <bsd.port.mk>