aboutsummaryrefslogtreecommitdiff
path: root/devel/cvsgraph/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-02-25 03:13:11 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-02-25 03:13:11 +0000
commitb2da0c288352f7c512c83067107ca39a8a841564 (patch)
tree4784b2103d09df0e17638660c4f891099ed0f93a /devel/cvsgraph/Makefile
parent83dc615256644f23276eaff158405ca9a25937d2 (diff)
Update to 1.0.1. The sorting bug has been fixed.
Notes
Notes: svn path=/head/; revision=38682
Diffstat (limited to 'devel/cvsgraph/Makefile')
-rw-r--r--devel/cvsgraph/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index 1798b239670e..61b90c19e0ee 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cvsgraph
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.1
CATEGORIES= devel graphics
MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/
@@ -19,8 +19,19 @@ LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
ALL_TARGET= cvsgraph
DOCDIR= share/doc/${PORTNAME}
-DOCS= LICENCE README
+DOCS= ChangeLog LICENCE README
PLIST= ${WRKDIR}/pkg-plist
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gd=${LOCALBASE} \
+ --with-png=${LOCALBASE} \
+ --with-z=/usr
+
+post-configure:
+ ${PERL} -pi -e \
+ "s|CFLAGS =|CFLAGS += -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/gd|g" \
+ ${WRKSRC}/Makefile
pre-install:
${ECHO} bin/cvsgraph > ${PLIST}