aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-tcl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2015-06-20 09:51:32 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2015-06-20 09:51:32 +0000
commit249b044e4f39ccb04467eafc40e98a2e27a7df40 (patch)
treeff1dfb9c8a25703722a0a9dc5bf4d4529824ce89 /devel/dbus-tcl/Makefile
parent20cc9f899ae7c492bc285815a6b3da2e3c1b25d0 (diff)
downloadports-249b044e4f39ccb04467eafc40e98a2e27a7df40.tar.gz
ports-249b044e4f39ccb04467eafc40e98a2e27a7df40.zip
- Update to 2.1
Changes: * Add support for passing file handles over the dbus. * Add a new dbus info subcommand to check if a dbus connection supports file descriptor passing. * Allow method scripts to decide at runtime if the response will be given asynchronous or not. * Do monitoring via a filter, rather than a fallback handler. That way also method_return- and error messages can be seen. * Accept server addresses as dbus identifiers for all commands. * Allow specifying an empty string for the dbus call -handler option, which will be handled the same as not having the option at all, i.e.: synchronous operation. * Properly handle 32- and 64-bit unsigned arguments * The unknown subcommand should also understand the -details option * Make sure type signatures and object paths are valid before passing them to dbus functions, because the library will panic on invalid values. * Implement "integer constant is too large" patch provided by Stuart. * Fix wrong return code from [dbus info capabilities]
Notes
Notes: svn path=/head/; revision=390157
Diffstat (limited to 'devel/dbus-tcl/Makefile')
-rw-r--r--devel/dbus-tcl/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/dbus-tcl/Makefile b/devel/dbus-tcl/Makefile
index 773dd4401584..234ae46dc447 100644
--- a/devel/dbus-tcl/Makefile
+++ b/devel/dbus-tcl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dbus-tcl
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/dbus/${PORTVERSION}/
DISTNAME= dbus-${PORTVERSION}
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
--exec-prefix=${PREFIX}
-PLIST_FILES= lib/dbus/libdbus20.so.1 \
+PLIST_FILES= lib/dbus/libdbus21.so.1 \
lib/dbus/pkgIndex.tcl \
man/mann/dbus.n.gz
@@ -33,6 +33,10 @@ PLIST_FILES= lib/dbus/libdbus20.so.1 \
BUILD_DEPENDS= dtplite:${PORTSDIR}/devel/tcllib
.endif
+post-patch:
+ ${REINPLACE_CMD} -e '/^INSTALL_PROGRAM/s|$$| -s|' \
+ ${WRKSRC}/Makefile.in
+
regression-test:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} test