aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-tcl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2020-05-06 09:47:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2020-05-06 09:47:52 +0000
commit50702b585be7c116a0df023d8b4a23c01046e50b (patch)
tree36cd62990d624c26a406dc32d01a2366f5cbddcd /devel/dbus-tcl/Makefile
parentd68cc132141d1a3458653bbc1726b0cd7efdffcf (diff)
downloadports-50702b585be7c116a0df023d8b4a23c01046e50b.tar.gz
ports-50702b585be7c116a0df023d8b4a23c01046e50b.zip
devel/dbus-tcl: make it build with out make, bump PORTREVISION
Notes
Notes: svn path=/head/; revision=534161
Diffstat (limited to 'devel/dbus-tcl/Makefile')
-rw-r--r--devel/dbus-tcl/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/devel/dbus-tcl/Makefile b/devel/dbus-tcl/Makefile
index cf05042eff24..97422226654e 100644
--- a/devel/dbus-tcl/Makefile
+++ b/devel/dbus-tcl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dbus-tcl
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= https://chiselapp.com/user/schelte/repository/dbus/uv/
DISTNAME= dbus-${PORTVERSION}
@@ -16,20 +16,22 @@ LICENSE= ISCL
LIB_DEPENDS= libdbus-1.so:devel/dbus
BUILD_DEPENDS= dtplite:devel/tcllib
+USES= pkgconfig tcl:tea
+
OPTIONS_DEFINE= DOCS
DOCSDIR= ${PREFIX}/share/doc/dbus
PORTDOCS= *
TEST_TARGET= do-test
-USES= gmake pkgconfig tcl:tea
-
PLIST_FILES= lib/dbus/libdbus21.so.1 \
lib/dbus/pkgIndex.tcl \
man/mann/dbus.n.gz
post-patch:
- ${REINPLACE_CMD} -e '/^INSTALL_PROGRAM/s|$$| -s|' \
+ ${REINPLACE_CMD} \
+ -e '/^INSTALL_PROGRAM/s|$$| -s|' \
+ -e 's|\$$\+|$$>|' \
${WRKSRC}/Makefile.in
do-test: