aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-tcl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-04-24 14:29:18 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-04-24 14:29:18 +0000
commitefecc3b668f3c0af32db9702708f36062fbcf98e (patch)
tree0e2c2000c9d1f4cbdeced4f728575679b1096dad /devel/dbus-tcl
parent04bb15a9f652d498b518e4a35ec007a5e941dac6 (diff)
downloadports-efecc3b668f3c0af32db9702708f36062fbcf98e.tar.gz
ports-efecc3b668f3c0af32db9702708f36062fbcf98e.zip
Notes
Diffstat (limited to 'devel/dbus-tcl')
-rw-r--r--devel/dbus-tcl/Makefile40
-rw-r--r--devel/dbus-tcl/distinfo2
-rw-r--r--devel/dbus-tcl/pkg-descr5
3 files changed, 47 insertions, 0 deletions
diff --git a/devel/dbus-tcl/Makefile b/devel/dbus-tcl/Makefile
new file mode 100644
index 000000000000..9f40b64c90ad
--- /dev/null
+++ b/devel/dbus-tcl/Makefile
@@ -0,0 +1,40 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= dbus-tcl
+PORTVERSION= 2.0
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}/dbus/${PORTVERSION}/
+DISTNAME= dbus-${PORTVERSION}
+
+MAINTAINER= tcltk@FreeBSD.org
+COMMENT= Tcl interface to the D-Bus messaging system
+
+LICENSE= ISCL
+
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+
+OPTIONS_DEFINE= DOCS
+DOCSDIR= ${PREFIX}/share/doc/dbus
+PORTDOCS= *
+
+USES= pkgconfig tcl:85+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
+ --exec-prefix=${PREFIX}
+
+PLIST_FILES= lib/dbus/libdbus20.so.1 \
+ lib/dbus/pkgIndex.tcl \
+ man/mann/dbus.n.gz
+PLIST_DIRS= lib/dbus
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS= dtplite:${PORTSDIR}/devel/tcllib
+.endif
+
+regression-test:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/devel/dbus-tcl/distinfo b/devel/dbus-tcl/distinfo
new file mode 100644
index 000000000000..60ed7d7b46f7
--- /dev/null
+++ b/devel/dbus-tcl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dbus-2.0.tar.gz) = 428b4045d395b0d26255730ce7c0d14850e45abb3c7cc6d9d48c1d2b723bb16a
+SIZE (dbus-2.0.tar.gz) = 170733
diff --git a/devel/dbus-tcl/pkg-descr b/devel/dbus-tcl/pkg-descr
new file mode 100644
index 000000000000..a27d1dc95bd7
--- /dev/null
+++ b/devel/dbus-tcl/pkg-descr
@@ -0,0 +1,5 @@
+The DBus-Tcl project provides a Tcl interface to the dbus message bus system.
+It contains packages that allow Tcl programs to send and receive dbus signals,
+as well as invoke and respond to dbus method calls.
+
+WWW: http://dbus-tcl.sf.net