aboutsummaryrefslogtreecommitdiff
path: root/devel/dconf-editor
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /devel/dconf-editor
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'devel/dconf-editor')
-rw-r--r--devel/dconf-editor/Makefile22
-rw-r--r--devel/dconf-editor/pkg-plist9
2 files changed, 31 insertions, 0 deletions
diff --git a/devel/dconf-editor/Makefile b/devel/dconf-editor/Makefile
new file mode 100644
index 000000000000..57e6d47e38ef
--- /dev/null
+++ b/devel/dconf-editor/Makefile
@@ -0,0 +1,22 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/devel/dconf-editor/Makefile,v 1.2 2012/12/16 22:43:23 kwm Exp $
+
+PORTNAME= dconf
+PKGNAMESUFFIX= -editor
+
+COMMENT= configuration editor for dconf
+
+DCONF_SLAVE= editor
+
+MASTERDIR= ${.CURDIR}/../dconf
+
+PLIST= ${.CURDIR}/pkg-plist
+
+do-build:
+ @cd ${WRKSRC}/editor && ${GMAKE}
+
+do-install:
+ @cd ${WRKSRC}/editor && ${GMAKE} install
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/dconf-editor/pkg-plist b/devel/dconf-editor/pkg-plist
new file mode 100644
index 000000000000..5c035237dba4
--- /dev/null
+++ b/devel/dconf-editor/pkg-plist
@@ -0,0 +1,9 @@
+bin/dconf-editor
+share/applications/dconf-editor.desktop
+share/dconf-editor/dconf-editor.ui
+share/icons/hicolor/128x128/apps/dconf-editor.png
+share/icons/hicolor/32x32/apps/dconf-editor.png
+share/icons/hicolor/48x48/apps/dconf-editor.png
+share/icons/hicolor/64x64/apps/dconf-editor.png
+@dirrm share/dconf-editor
+@dirrmtry share/applications