aboutsummaryrefslogtreecommitdiff
path: root/devel/dia2code/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:42:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:42:54 +0000
commitc33c11702c21c24076f15fa4dfeb8f35ef13773e (patch)
treeca4df7263253771f5b0f3b7a2bec878c617e64ce /devel/dia2code/Makefile
parent784e6b9ab15c49271b76177d42aef5caa85640e5 (diff)
downloadports-c33c11702c21c24076f15fa4dfeb8f35ef13773e.tar.gz
ports-c33c11702c21c24076f15fa4dfeb8f35ef13773e.zip
Notes
Diffstat (limited to 'devel/dia2code/Makefile')
-rw-r--r--devel/dia2code/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/dia2code/Makefile b/devel/dia2code/Makefile
index 8b15ffd20d1c..6536738264c4 100644
--- a/devel/dia2code/Makefile
+++ b/devel/dia2code/Makefile
@@ -7,26 +7,32 @@
#
PORTNAME= dia2code
-PORTVERSION= 0.8.3
+PORTVERSION= 0.8.4
CATEGORIES= devel
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A small utility used to generate code from a Dia diagram
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GNOME= libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
AUTOMAKE="${TRUE}"
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= dia2code.1
PLIST_FILES= bin/dia2code
post-patch:
@${REINPLACE_CMD} -e '/<malloc.h>/d' ${WRKSRC}/dia2code/dia2code.h
+ @${REINPLACE_CMD} -e 's|ulong|unsigned long|' ${WRKSRC}/dia2code/source_parser.[ch]
post-install:
${INSTALL_MAN} ${WRKSRC}/dia2code.1 ${MANPREFIX}/man/man1