aboutsummaryrefslogtreecommitdiff
path: root/devel/distorm
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-01-04 22:30:12 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-01-04 22:30:12 +0000
commit0d2af93f2bf89282a514441af5f4dc320c5d14f7 (patch)
tree8cef05a2a336a89756e49173b3f9b6ebca23061a /devel/distorm
parent0461a2d3aaacef7a39311436269e20bd2e9212f8 (diff)
downloadports-0d2af93f2bf89282a514441af5f4dc320c5d14f7.tar.gz
ports-0d2af93f2bf89282a514441af5f4dc320c5d14f7.zip
Notes
Diffstat (limited to 'devel/distorm')
-rw-r--r--devel/distorm/Makefile15
-rw-r--r--devel/distorm/distinfo4
-rw-r--r--devel/distorm/files/patch-make__linux__Makefile2
3 files changed, 10 insertions, 11 deletions
diff --git a/devel/distorm/Makefile b/devel/distorm/Makefile
index 0beb6f937340..cb1bae27d6d6 100644
--- a/devel/distorm/Makefile
+++ b/devel/distorm/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: distorm
-# Date created: 13 May 2008
-# Whom: bf <bf2006a@yahoo.com>
-#
+# Created by: bf <bf2006a@yahoo.com>
# $FreeBSD$
-#
PORTNAME?= distorm
-DISTVERSION= 20120514-r214
+DISTVERSION= 20121220-r230
PORTREVISION?= 0
CATEGORIES= devel
.if defined(PYTHON_SLAVEPORT)
@@ -30,11 +26,11 @@ USE_DOS2UNIX= yes
USE_XZ = yes
.if defined(PYTHON_SLAVEPORT)
-USE_PYTHON= -2.7
+USE_PYTHON= 2.6-2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= distorm3
-PYDISTUTILS_PKGVERSION = 2
+PYDISTUTILS_PKGVERSION = 3
PLIST_DIRS= %%PYTHON_SITELIBDIR%%/distorm3
@@ -88,6 +84,9 @@ do-build:
${CC} ${CFLAGS} ${LDFLAGS} -o ${BUILD_WRKSRC}/disasm \
${WRKSRC}/examples/linux/main.c ${BUILD_WRKSRC}/libdistorm3.a
+check regression-test test: build
+ @cd ${BUILD_WRKSRC}; ./disasm disasm
+
do-install:
@(cd ${BUILD_WRKSRC}; ${INSTALL_LIB} libdistorm3.a ${PREFIX}/lib; \
${INSTALL_LIB} libdistorm3.so ${PREFIX}/lib/libdistorm3.so.1; \
diff --git a/devel/distorm/distinfo b/devel/distorm/distinfo
index 95a84f0cc78d..f1889b6b1ab4 100644
--- a/devel/distorm/distinfo
+++ b/devel/distorm/distinfo
@@ -1,4 +1,4 @@
-SHA256 (distorm-20120514-r214.tar.xz) = 3e0c864abd6dbe24c0221f7f949019fb681952ea395f6de58569ed0d7ce0f04a
-SIZE (distorm-20120514-r214.tar.xz) = 147284
+SHA256 (distorm-20121220-r230.tar.xz) = 5c4df6e69f789ab5a0445a3355910c81c96fe3b0a6546689a19c87fd62089aa0
+SIZE (distorm-20121220-r230.tar.xz) = 150848
SHA256 (dislib.py) = ad2d3dda291887ec93f000e30e5f02a77f4e446be0c3042beb7b1e99c5e6e640
SIZE (dislib.py) = 27405
diff --git a/devel/distorm/files/patch-make__linux__Makefile b/devel/distorm/files/patch-make__linux__Makefile
index 6310cb7845fd..8a84cba59d7d 100644
--- a/devel/distorm/files/patch-make__linux__Makefile
+++ b/devel/distorm/files/patch-make__linux__Makefile
@@ -3,7 +3,7 @@
@@ -4,22 +4,23 @@
TARGET = libdistorm3.so
- COBJS = ../../src/mnemonics.o ../../src/wstring.o ../../src/textdefs.o ../../src/x86defs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
+ COBJS = ../../src/mnemonics.o ../../src/wstring.o ../../src/textdefs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
-CC = gcc
-CFLAGS = -fPIC -O2 -Wall -DSUPPORT_64BIT_OFFSET -DDISTORM_STATIC
+CFLAGS += -DSUPPORT_64BIT_OFFSET