aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-file
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
commit2d250bb95eac4419c2b2a81d30d1629c50a4ba4f (patch)
tree9c4bc08591050b7b536082be6db8392c913f8089 /devel/ecore-file
parent3f57bf2285e342135340477d9404790fda157f15 (diff)
downloadports-2d250bb95eac4419c2b2a81d30d1629c50a4ba4f.tar.gz
ports-2d250bb95eac4419c2b2a81d30d1629c50a4ba4f.zip
Notes
Diffstat (limited to 'devel/ecore-file')
-rw-r--r--devel/ecore-file/Makefile27
-rw-r--r--devel/ecore-file/distinfo4
-rw-r--r--devel/ecore-file/pkg-plist2
3 files changed, 17 insertions, 16 deletions
diff --git a/devel/ecore-file/Makefile b/devel/ecore-file/Makefile
index c16cb0a5263c..7a4b0a16eb88 100644
--- a/devel/ecore-file/Makefile
+++ b/devel/ecore-file/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= file
-DISTVERSION= 1.1.0
+PORTVERSION= 1.7.4
CATEGORIES= devel enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-12-02/base/
+ LOCAL/gblach/e17/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${DISTVERSION}
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= gblach@FreeBSD.org
COMMENT= Enlightenment core abstraction library (file module)
@@ -25,19 +25,20 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
.include "../ecore-main/Makefile.inc"
-CONFIGURE_ARGS+= --enable-ecore-file
+CONFIGURE_ARGS+=--enable-ecore-file
-OPTIONS= CURL "Enable Curl support" on
+OPTIONS_DEFINE= CURL
+OPTIONS_DEFAULT=CURL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_CURL)
-USE_EFL_ECORE= con
-CONFIGURE_ARGS+= --enable-ecore-con \
- --enable-curl
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.if ${PORT_OPTIONS:MCURL}
+USE_EFL_ECORE= con
+CONFIGURE_ARGS+=--enable-ecore-con \
+ --enable-curl
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
.else
-CONFIGURE_ARGS+= --disable-curl
+CONFIGURE_ARGS+=--disable-curl
.endif
post-patch:
@@ -56,4 +57,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ecore-file.pc \
${PREFIX}/libdata/pkgconfig/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ecore-file/distinfo b/devel/ecore-file/distinfo
index 30f1faeb45b9..e4794250dd2e 100644
--- a/devel/ecore-file/distinfo
+++ b/devel/ecore-file/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/ecore-1.1.0.tar.bz2) = c701a31941e178babad577ede886a98cf472352e5a73ee4717c0ffdc980152cc
-SIZE (e17/ecore-1.1.0.tar.bz2) = 3217298
+SHA256 (e17/ecore-1.7.4.tar.bz2) = 4fa52dece3cfeeb61c89038391c5c25ff31911a6dd187229f8ddb0a1bd61a03d
+SIZE (e17/ecore-1.7.4.tar.bz2) = 3421866
diff --git a/devel/ecore-file/pkg-plist b/devel/ecore-file/pkg-plist
index 8c6a5b52a3d3..423c3778b199 100644
--- a/devel/ecore-file/pkg-plist
+++ b/devel/ecore-file/pkg-plist
@@ -1,5 +1,5 @@
include/ecore-1/Ecore_File.h
lib/libecore_file.so
-lib/libecore_file.so.2
+lib/libecore_file.so.8
libdata/pkgconfig/ecore-file.pc
@dirrmtry include/ecore-1