aboutsummaryrefslogtreecommitdiff
path: root/devel/ecore-main
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /devel/ecore-main
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'devel/ecore-main')
-rw-r--r--devel/ecore-main/Makefile32
-rw-r--r--devel/ecore-main/Makefile.inc17
-rw-r--r--devel/ecore-main/distinfo5
-rw-r--r--devel/ecore-main/pkg-plist16
4 files changed, 41 insertions, 29 deletions
diff --git a/devel/ecore-main/Makefile b/devel/ecore-main/Makefile
index 38c26cb32926..df8e3b9285a5 100644
--- a/devel/ecore-main/Makefile
+++ b/devel/ecore-main/Makefile
@@ -6,34 +6,26 @@
#
PORTNAME= main
-PORTVERSION= 0.9.9.042
-PORTREVISION= 0
-CATEGORIES= devel
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= devel enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (main library)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= eina libtool_hack
+USE_GETTEXT= yes
USE_GNOME= gnomehack pkgconfig gnometarget
+USE_ICONV= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-ecore-con \
- --disable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --disable-ecore-file \
- --disable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --disable-ecore-x \
- --disable-ecore-imf \
- --disable-ecore-imf_evas
+.include "Makefile.inc"
.include <bsd.port.mk>
diff --git a/devel/ecore-main/Makefile.inc b/devel/ecore-main/Makefile.inc
new file mode 100644
index 000000000000..acd6e9a32173
--- /dev/null
+++ b/devel/ecore-main/Makefile.inc
@@ -0,0 +1,17 @@
+CONFIGURE_ARGS= --disable-ecore-con \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --disable-glib \
+ --disable-gnutls \
+ --disable-ecore-imf \
+ --disable-ecore-imf_evas \
+ --disable-ecore-input \
+ --disable-ecore-input_evas \
+ --disable-ecore-ipc \
+ --disable-ecore-sdl \
+ --disable-ecore-x
+
+post-patch: ecore_drop_librt
+ecore_drop_librt:
+ @${REINPLACE_CMD} -E -e 's,(rt_libs=).*,\1,g' ${WRKSRC}/configure
diff --git a/devel/ecore-main/distinfo b/devel/ecore-main/distinfo
index 4672f6a1c167..36d07e85437a 100644
--- a/devel/ecore-main/distinfo
+++ b/devel/ecore-main/distinfo
@@ -1,3 +1,2 @@
-MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
-SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
-SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/devel/ecore-main/pkg-plist b/devel/ecore-main/pkg-plist
index 69033dfea741..c5410f86f381 100644
--- a/devel/ecore-main/pkg-plist
+++ b/devel/ecore-main/pkg-plist
@@ -1,8 +1,12 @@
-include/Ecore.h
-include/Ecore_Data.h
-include/Ecore_Str.h
-lib/libecore.a
-lib/libecore.la
+include/ecore-1/Ecore.h
+include/ecore-1/Ecore_Getopt.h
lib/libecore.so
-lib/libecore.so.9
+lib/libecore.so.1
libdata/pkgconfig/ecore.pc
+share/locale/cs/LC_MESSAGES/ecore.mo
+share/locale/de/LC_MESSAGES/ecore.mo
+share/locale/el/LC_MESSAGES/ecore.mo
+share/locale/fr/LC_MESSAGES/ecore.mo
+share/locale/it/LC_MESSAGES/ecore.mo
+share/locale/pt/LC_MESSAGES/ecore.mo
+@dirrmtry include/ecore-1