aboutsummaryrefslogtreecommitdiff
path: root/devel/efl/Makefile
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2014-12-07 11:22:39 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2014-12-07 11:22:39 +0000
commit1ad2a9a1b96fa2d2bdb995c693e5f6a1e3bbad29 (patch)
treebc659c50ea96a1ecb72635cb5d05b582732a2ab6 /devel/efl/Makefile
parent5a46893045847e41fec4ef775c0f0bf8e1f90c70 (diff)
downloadports-1ad2a9a1b96fa2d2bdb995c693e5f6a1e3bbad29.tar.gz
ports-1ad2a9a1b96fa2d2bdb995c693e5f6a1e3bbad29.zip
Notes
Diffstat (limited to 'devel/efl/Makefile')
-rw-r--r--devel/efl/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index ee01ade57c44..6d9412dec5bc 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -36,7 +36,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= BRANCHVERSION=${PORTVERSION:R} PORTVERSION=${PORTVERSION}
-OPTIONS_DEFINE= AVAHI FRIBIDI HARFBUZZ PHYSICS PULSEAUDIO SSL
+OPTIONS_DEFINE= AVAHI FRIBIDI HARFBUZZ NVIDIA PHYSICS PULSEAUDIO SSL
OPTIONS_GROUP= ENGINE EMOTION INPUT LOADER
OPTIONS_GROUP_ENGINE= OPENGL SDL
OPTIONS_GROUP_EMOTION= GSTREAMER LIBXINE V4L
@@ -46,6 +46,7 @@ OPTIONS_DEFAULT= FRIBIDI HARFBUZZ PHYSICS SSL OPENGL GSTREAMER
OPTIONS_SUB= yes
HARFBUZZ_DESC= OpenType text shaping engine
+NVIDIA_DESC= Apply Nvidia workaround
PHYSICS_DESC= Physics effects
IBUS_DESC= Intelligent Input Bus
SCIM_DESC= Smart Common Input Method
@@ -98,6 +99,10 @@ NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MNVIDIA}
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-lib-ecore_x-ecore_x_vsync_tool.c
+.endif
+
.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
WITH_OPENSSL_PORT= yes