aboutsummaryrefslogtreecommitdiff
path: root/devel/efl
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 11:39:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 11:39:00 +0000
commitace46b7ff25f5df18b63b00e6b5134d3fc66cbd4 (patch)
tree72619faa488fef93d6710b2b3189fde9ac63227d /devel/efl
parentb132573e497440ccab95f08970f076144dbea023 (diff)
downloadports-ace46b7ff25f5df18b63b00e6b5134d3fc66cbd4.tar.gz
ports-ace46b7ff25f5df18b63b00e6b5134d3fc66cbd4.zip
devel: Add missing USES={gl,gnome,php,sdl}
Notes
Notes: svn path=/head/; revision=517048
Diffstat (limited to 'devel/efl')
-rw-r--r--devel/efl/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index f839a01a8762..cfb0cb6f9c2b 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -26,8 +26,8 @@ LIB_DEPENDS= libgif.so:graphics/giflib \
CONFLICTS_INSTALL= libeio
GNU_CONFIGURE= yes
-USES= autoreconf compiler:c++14-lang gettext-tools gmake iconv jpeg \
- libtool pathfix pkgconfig python:2.7,run shared-mime-info \
+USES= autoreconf compiler:c++14-lang gettext-tools gmake gnome iconv \
+ jpeg libtool pathfix pkgconfig python:2.7,run shared-mime-info \
shebangfix tar:xz xorg
SHEBANG_FILES= src/scripts/eina/eina-bench-cmp
USE_XORG= x11 xcb xcursor xcomposite xdamage xext xfixes xi xinerama \
@@ -136,11 +136,14 @@ WEBP_CONFIGURE_ENABLE= image-loader-webp
XCF_CONFIGURE_ENABLE= xcf
+OPENGL_USES= gl
OPENGL_USE= GL=gl
+OPENGLES_USES= gl
OPENGLES_USE= GL=glesv2
OPENGLES_CONFIGURE_ON= --with-opengl=es --enable-egl
+SDL_USES= sdl
SDL_USE= SDL=sdl2
SDL_CONFIGURE_ENABLE= sdl