aboutsummaryrefslogtreecommitdiff
path: root/devel/egypt
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /devel/egypt
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'devel/egypt')
-rw-r--r--devel/egypt/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/egypt/Makefile b/devel/egypt/Makefile
index c1735d1cce4f..b91850a14ed3 100644
--- a/devel/egypt/Makefile
+++ b/devel/egypt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= egypt
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= http://www.gson.org/egypt/download/ CENKES
@@ -16,8 +17,6 @@ USES= perl5 shebangfix
USE_PERL5= configure
SHEBANG_FILES= egypt
-PLIST_FILES= bin/${PORTNAME} %%SITE_PERL%%/%%PERL_ARCH%%/auto/${PORTNAME}/.packlist \
- man/man1/egypt.1.gz
-PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} man/man1/egypt.1.gz
.include <bsd.port.mk>