aboutsummaryrefslogtreecommitdiff
path: root/devel/eric6
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /devel/eric6
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'devel/eric6')
-rw-r--r--devel/eric6/Makefile18
-rw-r--r--devel/eric6/Makefile.inc2
2 files changed, 10 insertions, 10 deletions
diff --git a/devel/eric6/Makefile b/devel/eric6/Makefile
index 0000f896eff2..c0384383a283 100644
--- a/devel/eric6/Makefile
+++ b/devel/eric6/Makefile
@@ -5,15 +5,15 @@ PORTREVISION= 1
CATEGORIES= devel python
DISTNAME= ${PORTNAME}-${PORTVERSION}
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtGui.so:x11-toolkits/py-qt${PYQTVER}-gui \
- ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/Qsci.so:devel/py-qt${PYQTVER}-qscintilla2
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtGui.so:x11-toolkits/py-qt${PYQTVER}-gui@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/Qsci.so:devel/py-qt${PYQTVER}-qscintilla2@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS} \
- ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtNetwork.so:net/py-qt${PYQTVER}-network \
- ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtSvg.so:graphics/py-qt${PYQTVER}-svg \
- ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtSql.so:databases/py-qt${PYQTVER}-sql \
- ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtWebKit.so:www/py-qt${PYQTVER}-webkit \
- ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtHelp.so:devel/py-qt${PYQTVER}-help \
- ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtNetwork.so:net/py-qt${PYQTVER}-network@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtSvg.so:graphics/py-qt${PYQTVER}-svg@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtSql.so:databases/py-qt${PYQTVER}-sql@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtWebKit.so:www/py-qt${PYQTVER}-webkit@${PY_FLAVOR} \
+ ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtHelp.so:devel/py-qt${PYQTVER}-help@${PY_FLAVOR} \
+ ${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3@${PY_FLAVOR}
USES= desktop-file-utils
INSTALL_CMD= install.py -c -f eric6config.freebsd -i ${STAGEDIR} --pyqt=${PYQTVER}
@@ -28,7 +28,7 @@ PYQT4_DESC= Python bindings for Qt4
PYQT4_VARS= PYQTVER=4
PYQT5_DESC= Python bindings for Qt5
PYQT5_VARS= PYQTVER=5
-PYQT5_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt5/QtWebKitWidgets.so:www/py-qt5-webkitwidgets
+PYQT5_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt5/QtWebKitWidgets.so:www/py-qt5-webkitwidgets@${PY_FLAVOR}
EXTRA_PATCHES=
MASTERPORT=
diff --git a/devel/eric6/Makefile.inc b/devel/eric6/Makefile.inc
index 4908bdb1d159..2435999b4c04 100644
--- a/devel/eric6/Makefile.inc
+++ b/devel/eric6/Makefile.inc
@@ -22,7 +22,7 @@ I18N_LANG?= ru
INSTALL_CMD?= install-i18n.py -p ${STAGEDIR}
MAKE_ENV+= "HOME=${WRKDIR}"
-USES+= python
+USES+= python:2.7
NO_BUILD= yes
PLIST_FILES?= %%DATADIR%%/i18n/${PORTNAME}_${I18N_LANG}.qm
EXTRA_PATCHES?= ${.CURDIR}/../../devel/eric6/files/extra-patch-install-i18n.py