aboutsummaryrefslogtreecommitdiff
path: root/devel/etoile-collectionkit
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:26:23 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-12-23 10:26:23 +0000
commit7bd84323106d03c2959e52613e5a608277ede726 (patch)
tree77310994fff24ca3b610b60b04e28410b9e4cbe4 /devel/etoile-collectionkit
parentfec4d8975ec69330de97d4b540e32d856a740ef3 (diff)
downloadports-7bd84323106d03c2959e52613e5a608277ede726.tar.gz
ports-7bd84323106d03c2959e52613e5a608277ede726.zip
Notes
Diffstat (limited to 'devel/etoile-collectionkit')
-rw-r--r--devel/etoile-collectionkit/Makefile33
-rw-r--r--devel/etoile-collectionkit/distinfo3
-rw-r--r--devel/etoile-collectionkit/pkg-descr17
-rw-r--r--devel/etoile-collectionkit/pkg-plist14
4 files changed, 67 insertions, 0 deletions
diff --git a/devel/etoile-collectionkit/Makefile b/devel/etoile-collectionkit/Makefile
new file mode 100644
index 000000000000..a9f21840d005
--- /dev/null
+++ b/devel/etoile-collectionkit/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: etoile-collectionkit
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= collectionkit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~%%SUBDIR%%/distfiles/
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Provides a common storage facility for records with properties
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+DEFAULT_LIBVERSION= 0.1
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/CollectionKit
+
+.include <bsd.port.mk>
diff --git a/devel/etoile-collectionkit/distinfo b/devel/etoile-collectionkit/distinfo
new file mode 100644
index 000000000000..545ac18e8091
--- /dev/null
+++ b/devel/etoile-collectionkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (Etoile-20061221.tar.bz2) = 120ffa8cf06c58ff775f8a218ad91448
+SHA256 (Etoile-20061221.tar.bz2) = 7dc8acbf2cb46d9d119c9817204bbbbe72884065f3287877550c400e68f4c992
+SIZE (Etoile-20061221.tar.bz2) = 9867481
diff --git a/devel/etoile-collectionkit/pkg-descr b/devel/etoile-collectionkit/pkg-descr
new file mode 100644
index 000000000000..5f667df10fcb
--- /dev/null
+++ b/devel/etoile-collectionkit/pkg-descr
@@ -0,0 +1,17 @@
+CollectionKit provides a common storage facility for records with properties,
+such as contact information, playlist, bookmark, etc.
+These records have defined structure (property-value relationship)
+which can be handled better than general property list.
+But values of these properties are too flexible to be stored in database,
+for example, a contact information may have multipe home phone numbers.
+Records can be grouped and groups can have groups inside.
+AddressBook framework from Apple provides a good machenism of handling
+these kind of records and Addresses for GNUstep implements the same interface.
+CollectionKit aims to provide a general storage facility based on
+Addresses for GNUstep so that other applications and frameworks
+can easily handle their information in the same manner.
+CollectionKit provide very little pre-defined properties.
+Therefore, a framework on top of CollectionKit is needed
+if the information is intended to be shared by many applications.
+
+WWW: http://www.etoile-project.org/
diff --git a/devel/etoile-collectionkit/pkg-plist b/devel/etoile-collectionkit/pkg-plist
new file mode 100644
index 000000000000..fbee8b935778
--- /dev/null
+++ b/devel/etoile-collectionkit/pkg-plist
@@ -0,0 +1,14 @@
+Local/Library/Headers/CollectionKit/CKCollection.h
+Local/Library/Headers/CollectionKit/CKCollectionView.h
+Local/Library/Headers/CollectionKit/CKGlobals.h
+Local/Library/Headers/CollectionKit/CKGroup.h
+Local/Library/Headers/CollectionKit/CKItem.h
+Local/Library/Headers/CollectionKit/CKMultiValue.h
+Local/Library/Headers/CollectionKit/CKRecord.h
+Local/Library/Headers/CollectionKit/CKSearchElement.h
+Local/Library/Headers/CollectionKit/CKTypedefs.h
+Local/Library/Headers/CollectionKit/CollectionKit.h
+Local/Library/Libraries/libCollectionKit.so
+Local/Library/Libraries/libCollectionKit.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libCollectionKit.so.%%LIBVERSION%%
+@dirrm Local/Library/Headers/CollectionKit