aboutsummaryrefslogtreecommitdiff
path: root/devel/exercisix
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-18 10:10:07 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-18 10:10:07 +0000
commit0ae755ed3410657b7f1fc6a4002839e2c55a31b1 (patch)
tree3ae69d209ca3a9052483c55ce0dc8fccfbe4fc06 /devel/exercisix
parent6df53c4b7a78ca483dc0e88a8d967ca358b6ad7a (diff)
downloadports-0ae755ed3410657b7f1fc6a4002839e2c55a31b1.tar.gz
ports-0ae755ed3410657b7f1fc6a4002839e2c55a31b1.zip
Notes
Diffstat (limited to 'devel/exercisix')
-rw-r--r--devel/exercisix/Makefile7
-rw-r--r--devel/exercisix/files/patch-Makefile19
-rw-r--r--devel/exercisix/pkg-plist3
3 files changed, 24 insertions, 5 deletions
diff --git a/devel/exercisix/Makefile b/devel/exercisix/Makefile
index b5980a6147e6..7cac51bddb96 100644
--- a/devel/exercisix/Makefile
+++ b/devel/exercisix/Makefile
@@ -9,9 +9,8 @@ MASTER_SITES= http://alexanderchuranov.com/files/
MAINTAINER= exercisix@alexanderchuranov.com
COMMENT= Innovative lightweight unit-test framework for C++
-USE_BZIP2= YES
-MAN3= exercisix.3
-MANCOMPRESSED= yes
+USE_BZIP2= yes
+
+OPTIONS_DEFINE= EXAMPLES
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/exercisix/files/patch-Makefile b/devel/exercisix/files/patch-Makefile
new file mode 100644
index 000000000000..ab0432de0f9c
--- /dev/null
+++ b/devel/exercisix/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- ./Makefile.orig 2014-02-18 11:06:36.485355646 +0100
++++ ./Makefile 2014-02-18 11:07:14.494356722 +0100
+@@ -22,12 +22,12 @@
+ .PHONY: clean
+
+ install: all $(FILESDIR)
+- install -o root -g wheel -m 444 $(FILES) $(FILESDIR)
+- install -C -o root -g wheel -m 444 $(INCS) $(INCLUDEDIR)
+- install -o root -g wheel -m 444 $(COMPRESSED_MAN) $(MANDIR)3
++ install -o root -g wheel -m 444 $(FILES) $(DESTDIR)$(FILESDIR)
++ install -C -o root -g wheel -m 444 $(INCS) $(DESTDIR)$(INCLUDEDIR)
++ install -o root -g wheel -m 444 $(COMPRESSED_MAN) $(DESTDIR)$(MANDIR)3
+
+ $(FILESDIR):
+- mkdir $(FILESDIR)
++ mkdir $(DESTDIR)$(FILESDIR)
+
+ deinstall:
+ rm -r $(FILESDIR)
diff --git a/devel/exercisix/pkg-plist b/devel/exercisix/pkg-plist
index 40b9bbff9c23..bf6f2c1cefce 100644
--- a/devel/exercisix/pkg-plist
+++ b/devel/exercisix/pkg-plist
@@ -1,4 +1,5 @@
include/exercisix.hh
share/examples/exercisix/BSDmakefile
share/examples/exercisix/example.cc
-@dirrm share/examples/exercisix
+man/man3/exercisix.3.gz
+@dirrm %%EXAMPLESDIR%%