aboutsummaryrefslogtreecommitdiff
path: root/devel/fbthrift
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-05-08 09:44:49 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-05-08 09:48:58 +0000
commit7bfbd1d1f55a76537ef8923b903507f9a682bcb8 (patch)
tree14da231eb396e7837850b24f039d24eba637470f /devel/fbthrift
parent4a035a23e2a935af6679f6209cf0adeb00fa98c9 (diff)
downloadports-7bfbd1d1f55a76537ef8923b903507f9a682bcb8.tar.gz
ports-7bfbd1d1f55a76537ef8923b903507f9a682bcb8.zip
devel/fbthrift: Fix build with ninja >= 1.12.0
Address a potential race condition where generated headers not created before they used in the build. https://github.com/facebook/fbthrift/pull/599 PR: 278693 Approved by: portmgr (blanket)
Diffstat (limited to 'devel/fbthrift')
-rw-r--r--devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt b/devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt
new file mode 100644
index 000000000000..b5d6202999fc
--- /dev/null
+++ b/devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt
@@ -0,0 +1,18 @@
+Fix race condition with Ninja >= 1.12.0 where any_rep_types.h is not generated
+before Any.cpp is compiled.
+
+https://github.com/facebook/fbthrift/pull/599
+
+--- thrift/lib/cpp2/CMakeLists.txt.orig 2024-05-02 22:42:02 UTC
++++ thrift/lib/cpp2/CMakeLists.txt
+@@ -109,8 +109,8 @@ add_library(
+ type/TypeRegistry.cpp
+ type/UniversalName.cpp
+ )
+-add_dependencies(thrifttype type-cpp2-target thriftannotation thrifttyperep
+- thriftprotocol)
++add_dependencies(thrifttype any_rep-cpp2-target type-cpp2-target
++ thriftannotation thrifttyperep thriftprotocol)
+ target_link_libraries(
+ thrifttype
+ PUBLIC