aboutsummaryrefslogtreecommitdiff
path: root/devel/fc++/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-27 19:11:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-27 19:11:56 +0000
commit037f1b62252a1fe9352b19384cd456c0df804847 (patch)
tree835154c827c5d0dcbafd3a5d6582fe06b60c36fb /devel/fc++/Makefile
parent528bc62a9ea806061c022e23a0e5ddeb09ef3fb8 (diff)
downloadports-037f1b62252a1fe9352b19384cd456c0df804847.tar.gz
ports-037f1b62252a1fe9352b19384cd456c0df804847.zip
Notes
Diffstat (limited to 'devel/fc++/Makefile')
-rw-r--r--devel/fc++/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/devel/fc++/Makefile b/devel/fc++/Makefile
index d7d242e3d348..cab0e5d30c29 100644
--- a/devel/fc++/Makefile
+++ b/devel/fc++/Makefile
@@ -1,27 +1,25 @@
-# ex:ts=8
-# New ports collection makefile for: fc++
-# Date created: Oct 10, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= fc++
PORTVERSION= 1.5
CATEGORIES= devel
-MASTER_SITES= http://www.cc.gatech.edu/~yannis/fc++/
-DISTNAME= FC++.${PORTVERSION}
+MASTER_SITES= http://people.cs.umass.edu/~yannis/fc++/
+DISTNAME= ${PORTNAME:U}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Functional Programming in C++
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-10-20
+OPTIONS_DEFINE= DOCS
NO_BUILD= yes
do-install:
@${MKDIR} ${PREFIX}/include/fc++
- ${CP} ${WRKSRC}/*.h ${PREFIX}/include/fc++
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/fc++
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/changes.html ${DOCSDIR}
+.endif
.include <bsd.port.mk>