aboutsummaryrefslogtreecommitdiff
path: root/devel/ffcall/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-08-04 12:05:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-08-04 12:05:30 +0000
commita0ee891653c00fa78237eac52063fd2be29eb730 (patch)
tree5fe659634fd42653d4f3108e728b6504958a426d /devel/ffcall/Makefile
parentd2a2dca401559df1daae49cd284d90f5d2afe322 (diff)
downloadports-a0ee891653c00fa78237eac52063fd2be29eb730.tar.gz
ports-a0ee891653c00fa78237eac52063fd2be29eb730.zip
Notes
Diffstat (limited to 'devel/ffcall/Makefile')
-rw-r--r--devel/ffcall/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/ffcall/Makefile b/devel/ffcall/Makefile
index e0298d756cb3..2579716a4a45 100644
--- a/devel/ffcall/Makefile
+++ b/devel/ffcall/Makefile
@@ -18,9 +18,17 @@ COMMENT= Foreign function call libraries
USE_GMAKE= yes
USE_LIBTOOL_VER= 13
-ONLY_FOR_ARCHS= i386 alpha ia64
+NOT_FOR_ARCHS= sparc64
MAN3= avcall.3 callback.3 trampoline.3 trampoline_r.3 vacall.3
MANCOMPRESSED= no
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+.endif
+
+.include <bsd.port.post.mk>