aboutsummaryrefslogtreecommitdiff
path: root/devel/florist/files
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 06:46:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 06:46:04 +0000
commit36c5a39f05e26c47327a0b7034622c9ee5d8100c (patch)
tree690302331d7ad79ce8c835625f8d92680f820f8a /devel/florist/files
parentfe840965796f04e113c9beeceba034258223788c (diff)
New port: florist (Ada-POSIX bindings)
FLORIST is a FSU implementation of POSIX.5 WWW: http://www.gnat.com/ PR: ports/42280 Submitted by: Vadim Godunko <vgodunko@vipmail.ru> <vgodunko@rost.ru>
Notes
Notes: svn path=/head/; revision=89520
Diffstat (limited to 'devel/florist/files')
-rw-r--r--devel/florist/files/Makefile.bsd7
-rw-r--r--devel/florist/files/patch-c-posix.c23
-rw-r--r--devel/florist/files/patch-configure.in23
-rw-r--r--devel/florist/files/pconfig.FreeBSD5
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/florist/files/Makefile.bsd b/devel/florist/files/Makefile.bsd
new file mode 100644
index 000000000000..3414af1ca145
--- /dev/null
+++ b/devel/florist/files/Makefile.bsd
@@ -0,0 +1,7 @@
+all:
+ @${GMAKE} GNATMAKEFLAGS1B="-O2 -fPIC"
+ @${LOCALBASE}/bin/adagcc -shared -Wl,-soname,libflorist-${PORTVERSION}.so.1 \
+ -o libflorist-${PORTVERSION}.so.1 *.o
+ @${LN} -sf libflorist-${PORTVERSION}.so.1 \
+ libflorist-${PORTVERSION}.so
+ @${RM} -f floristlib/deps* floristlib/gnatprep*
diff --git a/devel/florist/files/patch-c-posix.c b/devel/florist/files/patch-c-posix.c
new file mode 100644
index 000000000000..679dc1a78f74
--- /dev/null
+++ b/devel/florist/files/patch-c-posix.c
@@ -0,0 +1,23 @@
+--- c-posix.c.orig Thu Oct 24 01:03:51 2002
++++ c-posix.c Fri Sep 26 23:38:36 2003
+@@ -2788,7 +2788,11 @@
+ #endif
+
+ #ifdef SEM_VALUE_MAX
++#if SEM_VALUE_MAX > INT_MAX
++ gmaxnn("Semaphores_Value",INT_MAX);
++#else
+ gmaxnn("Semaphores_Value",SEM_VALUE_MAX);
++#endif
+ #else
+ #ifdef _POSIX_SEM_VALUE_MAX
+ gmaxn("Semaphores_Value",_POSIX_SEM_VALUE_MAX);
+@@ -6344,7 +6348,7 @@
+ g_struct_msghdr();
+ gcmnt("local socket address");
+ { struct sockaddr_un DUMMY;
+- ifprintf(fp," subtype sun_path_string is
++ ifprintf(fp," subtype sun_path_string is \
+ POSIX_String (1 .. %d);\n", sizeof (DUMMY.sun_path));
+ }
+ g_struct_sockaddr_un();
diff --git a/devel/florist/files/patch-configure.in b/devel/florist/files/patch-configure.in
new file mode 100644
index 000000000000..e5a0ac59afce
--- /dev/null
+++ b/devel/florist/files/patch-configure.in
@@ -0,0 +1,23 @@
+--- configure.in.orig Tue Jun 3 03:55:13 2003
++++ configure.in Tue Jun 3 03:58:10 2003
+@@ -104,6 +104,10 @@
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.LynxOS ./pconfig.h.in;
+ ;;
++ FreeBSD)
++ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
++ cp ./configs/pconfig.FreeBSD ./pconfig.h.in;
++ ;;
+ *)
+ echo "No Configuration for ${UNAME_SYSTEM}. Using default.";
+ cp ./configs/pconfig.Default ./pconfig.h.in;
+@@ -177,7 +181,8 @@
+ AC_POSIX_LIB(pthreads, pthread_self,,
+ AC_POSIX_LIB(cma, pthread_self,,
+ AC_POSIX_LIB(:libcma.a, pthread_self,,
+- AC_POSIX_LIB(thread, pthread_self))))))
++ AC_POSIX_LIB(thread, pthread_self,,
++ AC_POSIX_LIB(c_r, pthread_self)))))))
+ fi
+
+ AC_POSIX_LIB(aio, aio_read)
diff --git a/devel/florist/files/pconfig.FreeBSD b/devel/florist/files/pconfig.FreeBSD
new file mode 100644
index 000000000000..96a460f4eaff
--- /dev/null
+++ b/devel/florist/files/pconfig.FreeBSD
@@ -0,0 +1,5 @@
+#define _POSIX_C_SOURCE 199506L
+#define _XOPEN_SOURCE
+#define _XOPEN_SOURCE_EXTENDED 1
+#define _REENTRANT
+#define _P1003_1B_VISIBLE