aboutsummaryrefslogtreecommitdiff
path: root/devel/gamin
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-01-18 00:01:09 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-01-18 00:01:09 +0000
commit940b9ffea5246a8a4c6310036ac09bdcce8c30a7 (patch)
treef350139204181a20f9891f0182df6eb6c146b390 /devel/gamin
parent22d3bcf6526667b77f356c68f4eac41b5405f586 (diff)
downloadports-940b9ffea5246a8a4c6310036ac09bdcce8c30a7.tar.gz
ports-940b9ffea5246a8a4c6310036ac09bdcce8c30a7.zip
Notes
Diffstat (limited to 'devel/gamin')
-rw-r--r--devel/gamin/Makefile24
-rw-r--r--devel/gamin/files/patch-server__gam_node.h11
-rw-r--r--devel/gamin/files/patch-server__gam_subscription.c11
-rw-r--r--devel/gamin/files/patch-server__gam_subscription.h11
-rw-r--r--devel/gamin/files/patch-server_gam_node.c13
5 files changed, 55 insertions, 15 deletions
diff --git a/devel/gamin/Makefile b/devel/gamin/Makefile
index d56f4af553e0..609c7dc1d059 100644
--- a/devel/gamin/Makefile
+++ b/devel/gamin/Makefile
@@ -1,10 +1,6 @@
-# ports collection makefile for: gamin
-# Date created: 24 March 2005
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/devel/gamin/Makefile,v 1.6 2008/11/26 06:48:13 marcus Exp $
-#
+# $MCom: ports/devel/gamin/Makefile,v 1.11 2012/08/04 16:55:24 kwm Exp $
PORTNAME= gamin
PORTVERSION= 0.1.10
@@ -19,6 +15,7 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_GETTEXT= yes
USE_GNOME?= gnomehack _glib20
+USE_PKGCONFIG= build
USE_LDCONFIG= yes
CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc \
--without-python
@@ -30,21 +27,22 @@ CONFLICTS= fam-[0-9]*
GNU_CONFIGURE= yes
.if !defined(GAMIN_SLAVE)
-OPTIONS= GAM_POLLER "Use gamin's poller instead of kqueue's" off \
- LIBINOTIFY "Use libinotify as the FAM backend" off
+OPTIONS_DEFINE= GAM_POLLER LIBINOTIFY
+GAM_POLLER_DESC=Use gamin's poller instead of kqueue's
+LIBINOTIFY_DESC=Use libinotify as the FAM backend
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(GAMIN_SLAVE)
-.if defined(WITH_GAM_POLLER)
+.if ${PORT_OPTIONS:MGAM_POLLER}
CPPFLAGS+= -DUSE_GAMIN_POLLER=1
.endif
-.if defined(WITH_LIBINOTIFY)
+.if ${PORT_OPTIONS:MLIBINOTIFY}
CONFIGURE_ARGS+=--enable-inotify
LDFLAGS+= -L${LOCALBASE}/lib -linotify
-LIB_DEPENDS+= inotify.0:${PORTSDIR}/devel/libinotify
+LIB_DEPENDS+= inotify:${PORTSDIR}/devel/libinotify
.else
CONFIGURE_ARGS+=--disable-inotify
.endif
@@ -63,4 +61,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/gamin/files/patch-server__gam_node.h b/devel/gamin/files/patch-server__gam_node.h
new file mode 100644
index 000000000000..2490964c9f06
--- /dev/null
+++ b/devel/gamin/files/patch-server__gam_node.h
@@ -0,0 +1,11 @@
+--- server/gam_node.h.orig 2011-09-17 11:19:43.000000000 +0200
++++ server/gam_node.h 2011-09-17 11:20:13.000000000 +0200
+@@ -58,7 +58,7 @@ gboolean gam_node_is_dir
+ void gam_node_set_is_dir (GamNode *node,
+ gboolean is_dir);
+
+-G_CONST_RETURN char *gam_node_get_path (GamNode *node);
++const char *gam_node_get_path (GamNode *node);
+
+ GList *gam_node_get_subscriptions (GamNode *node);
+
diff --git a/devel/gamin/files/patch-server__gam_subscription.c b/devel/gamin/files/patch-server__gam_subscription.c
new file mode 100644
index 000000000000..4c14baecbdde
--- /dev/null
+++ b/devel/gamin/files/patch-server__gam_subscription.c
@@ -0,0 +1,11 @@
+--- server/gam_subscription.c.orig 2011-09-17 11:17:22.000000000 +0200
++++ server/gam_subscription.c 2011-09-17 11:17:44.000000000 +0200
+@@ -141,7 +141,7 @@ gam_subscription_pathlen(GamSubscription
+ * @param sub the GamSubscription
+ * @returns The path being monitored. It should not be freed.
+ */
+-G_CONST_RETURN char *
++const char *
+ gam_subscription_get_path(GamSubscription * sub)
+ {
+ if (sub == NULL)
diff --git a/devel/gamin/files/patch-server__gam_subscription.h b/devel/gamin/files/patch-server__gam_subscription.h
new file mode 100644
index 000000000000..b8d5c3467b8e
--- /dev/null
+++ b/devel/gamin/files/patch-server__gam_subscription.h
@@ -0,0 +1,11 @@
+--- server/gam_subscription.h.orig 2011-09-17 11:15:00.000000000 +0200
++++ server/gam_subscription.h 2011-09-17 11:15:18.000000000 +0200
+@@ -21,7 +21,7 @@ int gam_subscription_pa
+
+ int gam_subscription_get_reqno (GamSubscription *sub);
+
+-G_CONST_RETURN char *gam_subscription_get_path (GamSubscription *sub);
++const char *gam_subscription_get_path (GamSubscription *sub);
+
+ GamListener *gam_subscription_get_listener (GamSubscription *sub);
+
diff --git a/devel/gamin/files/patch-server_gam_node.c b/devel/gamin/files/patch-server_gam_node.c
index dbf7f638be5b..4330949d0d1a 100644
--- a/devel/gamin/files/patch-server_gam_node.c
+++ b/devel/gamin/files/patch-server_gam_node.c
@@ -1,5 +1,5 @@
---- server/gam_node.c.orig Thu Feb 9 01:22:56 2006
-+++ server/gam_node.c Thu Feb 9 01:23:03 2006
+--- server/gam_node.c.orig 2007-07-04 15:36:49.000000000 +0200
++++ server/gam_node.c 2011-09-17 11:19:10.000000000 +0200
@@ -23,6 +23,7 @@
#include "gam_event.h"
#include "gam_node.h"
@@ -8,3 +8,12 @@
/**
* Create a new node
+@@ -122,7 +123,7 @@ gam_node_set_is_dir(GamNode * node, gboo
+ * it has finished with the string. If it must keep it longer, it
+ * should makes its own copy. The returned string must not be freed.
+ */
+-G_CONST_RETURN char *
++const char *
+ gam_node_get_path(GamNode * node)
+ {
+ g_assert(node);