aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb/Makefile
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2015-04-29 13:53:45 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2015-04-29 13:53:45 +0000
commitbc869246e9838943d99c2c0e3f2bda6c325a77d0 (patch)
treed9bb7f99a01d6552a99e35414062781ad97ef441 /devel/gdb/Makefile
parent75e129eb678bbbb18714ffb57af493cd46d387c0 (diff)
downloadports-bc869246e9838943d99c2c0e3f2bda6c325a77d0.tar.gz
ports-bc869246e9838943d99c2c0e3f2bda6c325a77d0.zip
Notes
Diffstat (limited to 'devel/gdb/Makefile')
-rw-r--r--devel/gdb/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index a0427408a1d7..3413774c1dae 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gdb
-PORTVERSION= 7.8.2
-PORTREVISION= 2
+PORTVERSION= 7.9
CATEGORIES= devel
MASTER_SITES= GNU
@@ -27,6 +26,12 @@ CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT -Wno-unused-function -Wno-unused-variable
EXCLUDE= dejagnu expect sim texinfo intl
EXTRACT_AFTER_ARGS= ${EXCLUDE:S/^/--exclude /}
+EXTRA_PATCHES= ${FILESDIR}/commit-c5cb74e \
+ ${FILESDIR}/commit-cf424ae \
+ ${FILESDIR}/commit-773eacf \
+ ${FILESDIR}/commit-2526815 \
+ ${FILESDIR}/commit-3ce5b6e \
+ ${FILESDIR}/commit-97de354
VER= ${PORTVERSION:S/.//g}
PLIST_SUB= VER=${VER}
@@ -61,7 +66,6 @@ GUILE_LIB_DEPENDS= libguile-2.0.so:${PORTSDIR}/lang/guile2
PYTHON_CONFIGURE_ON= --with-python=${PYTHON_CMD}
PYTHON_CONFIGURE_OFF= --without-python
PYTHON_USES= python:2
-PORT_READLINE_EXTRA_PATCHES= ${FILESDIR}/extrapatch-gdb-tui-tui-io.c
PORT_READLINE_USES= readline:port
TUI_CONFIGURE_ENABLE= tui