aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb6/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-03-24 23:12:34 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-03-24 23:12:34 +0000
commit7c8519443689c59e05250eb7a1f3b778143884a3 (patch)
treea382ecc31c60caf7c0b82417c30cc08c31a4c383 /devel/gdb6/Makefile
parent5173d7ffaf07d1c34bf8e33364ef8d1a46c2caee (diff)
downloadports-7c8519443689c59e05250eb7a1f3b778143884a3.tar.gz
ports-7c8519443689c59e05250eb7a1f3b778143884a3.zip
Notes
Diffstat (limited to 'devel/gdb6/Makefile')
-rw-r--r--devel/gdb6/Makefile27
1 files changed, 19 insertions, 8 deletions
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index fc3e902bd307..4a182f499c64 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -6,25 +6,32 @@
# $FreeBSD$
#
-SNAPDATE= 2003-03-11
+SNAPDATE= 2004-03-23
SNAPVER= ${SNAPDATE:S/-//g}
PORTNAME= gdb
-PORTVERSION= 5.3
+PORTVERSION= 6
PORTREVISION= ${SNAPVER}
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= gdb/snapshots/branch
-DISTNAME= gdb+dejagnu-weekly-5.3.0.90_${SNAPVER}
+MASTER_SITE_SUBDIR= gdb/snapshots/current
+DISTNAME= gdb+dejagnu-weekly-${SNAPVER}
-MAINTAINER= mp@FreeBSD.org
-COMMENT= GNU GDB 5.3 developmental snapshot
+MAINTAINER= obrien@FreeBSD.org
+COMMENT= GNU GDB 6
WRKSRC= ${WRKDIR}/${DISTNAME:S/-weekly//}
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-suffix=53
+CONFIGURE_ARGS= --program-suffix=6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/$$/ [FreeBSD]/' ${WRKSRC}/gdb/version.in
+
+do-patch: post-patch
+ @${ECHO} 'FreeBSD-specific patches disabled for now, until upgraded.'
pre-configure:
cd ${WRKSRC} ; ${RM} -rf dejagnu expect sim tcl texinfo
@@ -35,7 +42,11 @@ do-install:
cklatest:
ncftpls \
- ftp://mirrors.rcn.net/mirrors/sources.redhat.com/${MASTER_SITE_SUBDIR}/ \
+ ftp://sources.redhat.com/pub/${MASTER_SITE_SUBDIR}/ \
| ${GREP} gdb+dejagnu-weekly
.include <bsd.port.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.endif