aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-11-28 15:32:45 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-11-28 15:32:45 +0000
commit87a5eb94230f58c86f9945f0987fef6e706b4d62 (patch)
tree29a029e2e5b7c674af8493332b77599a623be632 /devel/gdb
parent1fc9fdc1b351ddae55347915fe418e781b8043b9 (diff)
downloadports-87a5eb94230f58c86f9945f0987fef6e706b4d62.tar.gz
ports-87a5eb94230f58c86f9945f0987fef6e706b4d62.zip
devel/gdb: Add NLS option
Add NLS option (default ON, so no portrevision bump is needed) While I'm here, get rid of FreeBSD 10.x bits
Notes
Notes: svn path=/head/; revision=486096
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 20fcec3bd043..f92ff586108f 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -18,12 +18,10 @@ ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 mips powerpc powerpc64
LIB_DEPENDS= libmpfr.so:math/mpfr
TEST_DEPENDS= runtest:misc/dejagnu
+USES= compiler:c++11-lang cpe gmake libtool tar:xz
+
TEST_TARGET= check
-# XXX: This should be compiler:c++11-lib as GDB doesn't really require
-# C++14. However, clang in 10.3 crashes while building this port.
-# Requiring C++14 forces 10.3 to use an external version of clang while
-# still using the base system clang on 11.0 and later.
-USES= compiler:c++14-lang cpe gettext-runtime gmake libtool tar:xz
+
USE_CSTD= gnu89
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
@@ -46,9 +44,9 @@ LIB_DEPENDS+= libexpat.so:textproc/expat2
VER= ${PORTVERSION:S/.//g}
PLIST_SUB= VER=${VER}
-OPTIONS_DEFINE= DEBUG GDB_LINK GUILE KGDB PYTHON TUI
+OPTIONS_DEFINE= DEBUG GDB_LINK GUILE KGDB NLS PYTHON TUI
-OPTIONS_DEFAULT= GDB_LINK KGDB PYTHON TUI PORT_READLINE PORT_ICONV SYSTEM_ZLIB
+OPTIONS_DEFAULT= GDB_LINK KGDB NLS PYTHON TUI PORT_READLINE PORT_ICONV SYSTEM_ZLIB
OPTIONS_SINGLE= READLINE ICONV ZLIB
OPTIONS_SINGLE_READLINE= BUNDLED_READLINE PORT_READLINE
@@ -72,6 +70,7 @@ DEBUG_CFLAGS= -g
GUILE_CONFIGURE_WITH= guile
GUILE_USES= pkgconfig
GUILE_LIB_DEPENDS= libguile-2.0.so:lang/guile2
+NLS_USES= gettext-runtime
PORT_READLINE_USES= readline:port
PORT_ICONV_USES= iconv:wchar_t
PYTHON_CONFIGURE_ON= --with-python=${PYTHON_CMD}