aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2019-01-15 01:42:19 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2019-01-15 01:42:19 +0000
commit955fedfa2f77401345b4600b2c08405792be9f4f (patch)
tree48876abc27226fc6611ea0506abacf9063de7b8a /devel/gdb
parent9061a45b61cb3df00ded31224af495cd30708b25 (diff)
downloadports-955fedfa2f77401345b4600b2c08405792be9f4f.tar.gz
ports-955fedfa2f77401345b4600b2c08405792be9f4f.zip
Enable separate flavors for different python versions.
Since python is enabled by default, this keeps the version with the default python version as 'gdb' and adds a package suffix for other python versions. Reviewed by: pizzamig (maintainer) Differential Revision: https://reviews.freebsd.org/D18534
Notes
Notes: svn path=/head/; revision=490337
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 9bd78e3ad23a..7c3f60efc675 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libmpfr.so:math/mpfr
TEST_DEPENDS= runtest:misc/dejagnu
USES= compiler:c++11-lang cpe gmake libtool tar:xz
-USE_PYTHON= py3kplist
+USE_PYTHON= flavors py3kplist
TEST_TARGET= check
@@ -85,6 +85,12 @@ TUI_CONFIGURE_ENABLE= tui
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MPYTHON}
+.if ${PYTHON_VER} != ${PYTHON_DEFAULT}
+PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
+.endif
+.endif
+
.if ! ${PORT_OPTIONS:MBUNDLED_READLINE}
EXCLUDE+= readline
.endif