aboutsummaryrefslogtreecommitdiff
path: root/devel/geany-plugins
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-21 14:43:24 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-21 14:43:24 +0000
commit644aa2a709df1ebd5f141f8e4b28bb1efac1b304 (patch)
tree6835cf63cce00bf06d7c224b174cf4b2ee140939 /devel/geany-plugins
parentecd489ff2ae56355358396ff7131711ce603007c (diff)
downloadports-644aa2a709df1ebd5f141f8e4b28bb1efac1b304.tar.gz
ports-644aa2a709df1ebd5f141f8e4b28bb1efac1b304.zip
Notes
Diffstat (limited to 'devel/geany-plugins')
-rw-r--r--devel/geany-plugins/Makefile6
-rw-r--r--devel/geany-plugins/distinfo4
-rw-r--r--devel/geany-plugins/files/Makefile.common32
-rw-r--r--devel/geany-plugins/files/bsd.geany-plugins.mk28
-rw-r--r--devel/geany-plugins/files/extrapatch-configure72
5 files changed, 125 insertions, 17 deletions
diff --git a/devel/geany-plugins/Makefile b/devel/geany-plugins/Makefile
index 01a854dbdf3e..9998ee24759c 100644
--- a/devel/geany-plugins/Makefile
+++ b/devel/geany-plugins/Makefile
@@ -13,14 +13,20 @@ NO_BUILD= yes
.include "${.CURDIR}/files/bsd.geany-plugins.mk"
+OPTIONS_DEFINE= NLS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+# NLS option first, then plugins sorted in GEANY_PLUGINS_ALL
+NO_OPTIONS_SORT= yes
+
.for plugin in ${GEANY_PLUGINS_ALL}
OPTIONS_DEFINE+= ${plugin:U}
${plugin:U}_DESC= ${${plugin}_DESC}
${plugin:U}_DEP= geany-plugin-${plugin}>=0:${PORTSDIR}/devel/geany-plugin-${plugin}
.endfor
+NLS_DEP= geany-plugins-l10n>=0:${PORTSDIR}/devel/geany-plugins-l10n
+
.include <bsd.port.options.mk>
.for opt in ${OPTIONS_DEFINE}
diff --git a/devel/geany-plugins/distinfo b/devel/geany-plugins/distinfo
index 07d102e554ee..37ba0b62302e 100644
--- a/devel/geany-plugins/distinfo
+++ b/devel/geany-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (geany-plugins-1.22.tar.bz2) = a0dcf0cb00ac260670ef8fae682aade60c7c3075c88121fd21f3aecdff84e1ce
-SIZE (geany-plugins-1.22.tar.bz2) = 2088130
+SHA256 (geany-plugins-1.23.tar.bz2) = ff26860edd1cbaea88c73bd8c2bd02f9ba04046674f05d3696baf66582e2bf58
+SIZE (geany-plugins-1.23.tar.bz2) = 2811640
diff --git a/devel/geany-plugins/files/Makefile.common b/devel/geany-plugins/files/Makefile.common
index 79e25c08cb77..9fa41cd66d17 100644
--- a/devel/geany-plugins/files/Makefile.common
+++ b/devel/geany-plugins/files/Makefile.common
@@ -3,30 +3,37 @@
.include "${.CURDIR}/../../devel/geany-plugins/files/bsd.geany-plugins.mk"
MASTER_SITES= http://plugins.geany.org/geany-plugins/
-PKGNAMESUFFIX?= -${GEANY_PLUGIN}
DISTNAME= geany-plugins-${PORTVERSION}
DISTINFO_FILE= ${.CURDIR}/../../devel/geany-plugins/distinfo
-BUILD_DEPENDS+= ${LOCALBASE}/bin/geany:${PORTSDIR}/devel/geany \
- ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS+= ${LOCALBASE}/bin/geany:${PORTSDIR}/devel/geany
RUN_DEPENDS+= ${LOCALBASE}/bin/geany:${PORTSDIR}/devel/geany
CONFLICTS_INSTALL= geany-plugins-0.*
+EXTRA_PATCHES= ${.CURDIR}/../../devel/geany-plugins/files/extrapatch-configure
+
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS+= libtool
USE_PKGCONFIG= build
-USE_GETTEXT= yes
USE_GNOME+= gtk20
-GEANY_PLUGIN_DIR?= ${GEANY_PLUGIN}
-GEANY_PLUGIN_SWITCH?= --enable-${GEANY_PLUGIN_DIR}
+# geany-plugins-l10n is not a plugin, thus special treatment
+.if ${PORTNAME} == "geany-plugins-l10n"
+GEANY_PLUGIN= NLS
+NLS_DIR= po
+NLS_SWITCH= --enable-nls
+.endif
+
+GEANY_PLUGIN?= ${PORTNAME:S,geany-plugin-,,}
+${GEANY_PLUGIN}_DIR?= ${GEANY_PLUGIN}
+${GEANY_PLUGIN}_SWITCH?= --enable-${${GEANY_PLUGIN}_DIR}
-CONFIGURE_ARGS+= ${GEANY_PLUGIN_SWITCH}
+CONFIGURE_ARGS+= ${${GEANY_PLUGIN}_SWITCH}
-BUILD_WRKSRC= ${WRKSRC}/${GEANY_PLUGIN_DIR}
+BUILD_WRKSRC= ${WRKSRC}/${${GEANY_PLUGIN}_DIR}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
DATADIR= share/geany-plugins
@@ -34,15 +41,16 @@ DOCSDIR= share/doc/geany-plugins
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
+.if ${PORTNAME} != "geany-plugins-l10n"
+. if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-.else
+. else
CONFIGURE_ARGS+= --disable-nls
+. endif
.endif
pre-configure:
- ${REINPLACE_CMD} -e 's,/bin/sh,${LOCALBASE}/bin/bash,g' \
- -e 's,zlib,,g' \
+ ${REINPLACE_CMD} -e 's,zlib,,g' \
${WRKSRC}/configure
post-configure:
diff --git a/devel/geany-plugins/files/bsd.geany-plugins.mk b/devel/geany-plugins/files/bsd.geany-plugins.mk
index 0f725f9d680f..4987c65b3c2e 100644
--- a/devel/geany-plugins/files/bsd.geany-plugins.mk
+++ b/devel/geany-plugins/files/bsd.geany-plugins.mk
@@ -1,13 +1,13 @@
# $FreeBSD$
-GEANY_VER= 1.22
+GEANY_VER= 1.23
GEANY_PLUGINS_ALL= addons \
codenav \
+ commander \
debugger \
devhelp \
doc \
extrasel \
- gdb \
gendoc \
geniuspaste \
gproject \
@@ -22,6 +22,7 @@ GEANY_PLUGINS_ALL= addons \
pg \
pretty-printer \
prj \
+ scope \
sendmail \
shiftcolumn \
spellcheck \
@@ -32,13 +33,15 @@ GEANY_PLUGINS_ALL= addons \
webhelper \
xmlsnippets
+# markdown plugin is excluded, requires peg-markdown
+
addons_DESC= various small addons
codenav_DESC= some facilities for navigating in the code
+commander_DESC= command panel for rapid access to any action
debugger_DESC= debugging support (via GDB currently)
devhelp_DESC= API documentation browser
doc_DESC= execute command on the word at cursor position
extrasel_DESC= additional selection tools
-gdb_DESC= debugging support via the GNU Debugger
gendoc_DESC= generate documentation from the sources comments
geniuspaste_DESC= pastebins support
gproject_DESC= extension of Geany's project management
@@ -47,12 +50,14 @@ latex_DESC= LaTeX support
lipsum_DESC= Lorem Ipsum generator
lua_DESC= Lua scripting
macro_DESC= user defined macros
+# markdown_DESC= real-time preview of rendered Markdown
miniscript_DESC= pipe text/documents via script (shell, perl, awk, etc.)
multiterm_DESC= multi-tabbed virtual terminals emulator
numberedbookmarks_DESC= additional numbered bookmarks
pg_DESC= encrypt, decrypt and verify signatures with GnuPG
pretty-printer_DESC= formats XML and make it human-readable
prj_DESC= alternative project manager
+scope_DESC= graphical GDB front-end
sendmail_DESC= send a document as attachment
shiftcolumn_DESC= move blocks of text horizontally
spellcheck_DESC= spell check via Enchant
@@ -62,3 +67,20 @@ updatechecker_DESC= check for new version of Geany
vc_DESC= access to different version-control systems
webhelper_DESC= web development facilities
xmlsnippets_DESC= XML/HTML tag autocompletion
+
+doc_DIR= geanydoc
+extrasel_DIR= geanyextrasel
+gendoc_DIR= geanygendoc
+insertnum_DIR= geanyinsertnum
+latex_DIR= geanylatex
+lipsum_DIR= geanylipsum
+lua_DIR= geanylua
+macro_DIR= geanymacro
+miniscript_DIR= geanyminiscript
+numberedbookmarks_DIR= geanynumberedbookmarks
+pg_DIR= geanypg
+prj_DIR= geanyprj
+sendmail_DIR= geanysendmail
+vc_DIR= geanyvc
+
+pretty-printer_SWITCH= --enable-pretty_printer
diff --git a/devel/geany-plugins/files/extrapatch-configure b/devel/geany-plugins/files/extrapatch-configure
new file mode 100644
index 000000000000..ed7044c36f58
--- /dev/null
+++ b/devel/geany-plugins/files/extrapatch-configure
@@ -0,0 +1,72 @@
+--- ./configure.orig 2013-03-10 17:01:27.000000000 +0000
++++ ./configure 2013-03-21 00:22:04.580741068 +0000
+@@ -21101,69 +21101,3 @@
+ expanded_docdir=$(eval echo $expanded_docdir)
+
+
+- cat <<GPEOF
+-
+-${PACKAGE}-${VERSION}
+-
+- Build Environment:
+- Geany version: ${GEANY_VERSION}
+- Install prefix: ${prefix}
+- Datadir: ${expanded_datadir}/${PACKAGE_TARNAME}
+- Libdir: ${expanded_libdir}/${PACKAGE_TARNAME}
+- Docdir: ${expanded_docdir}
+- Plugins path: ${geanypluginsdir}
+-
+- Build Features:
+-GPEOF
+-
+-
+- while read line; do
+- test -z "$line" && break;
+- plugin=" ${line%:*}:"
+- status=${line#*:}
+- let extracols=34-${#plugin}
+- echo -n "$plugin"
+- for (( i=0; $i<$extracols; i++ )); do
+- echo -n ' '
+- done
+- echo $status
+- done << GPEOF
+-$build_feature_statusmsg
+-GPEOF
+-
+- echo
+- echo " Plugins:"
+-
+- while read line; do
+- test -z "$line" && break;
+- plugin=" ${line%:*}:"
+- status=${line#*:}
+- let extracols=34-${#plugin}
+- echo -n "$plugin"
+- for (( i=0; $i<$extracols; i++ )); do
+- echo -n ' '
+- done
+- echo $status
+- done << GPEOF
+-$plugins_statusmsg
+-GPEOF
+-
+- echo
+- echo " Features:"
+-
+- while read line; do
+- test -z "$line" && break;
+- plugin=" ${line%:*}:"
+- status=${line#*:}
+- let extracols=34-${#plugin}
+- echo -n "$plugin"
+- for (( i=0; $i<$extracols; i++ )); do
+- echo -n ' '
+- done
+- echo $status
+- done << GPEOF
+-$feature_statusmsg
+-GPEOF
+-
+- echo
+-