aboutsummaryrefslogtreecommitdiff
path: root/devel/gettext/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-04-02 12:25:24 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-04-02 12:25:24 +0000
commitd56569ff5759ea674905a34878ac40396bde1da6 (patch)
tree0063eea73d94b89bfdd7e48e104376f5575c04e2 /devel/gettext/Makefile
parent7190f8407777797706c915ce5085dd8e709e9823 (diff)
Notes
Diffstat (limited to 'devel/gettext/Makefile')
-rw-r--r--devel/gettext/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 20716bf9e10e..068612dd8e3c 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -31,6 +31,8 @@ CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib \
--mandir=${PREFIX}/man
INSTALLS_SHLIB= yes
+OPTIONS= EXAMPLES "install example files" off
+PLIST= ${WRKDIR}/plist
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
VERSION=${PORTVERSION}
@@ -68,10 +70,27 @@ post-build:
@sleep 5
.endif
+pre-install:
+ @${RM} -f ${PLIST}
+.if defined (WITH_EXAMPLES)
+ cd ${WRKSRC}/gettext-tools && \
+ ${FIND} -s examples -type f | ${GREP} -vw examples/po | \
+ ${GREP} -v ChangeLog | ${GREP} -v examples/Makefile | \
+ ${GREP} -v examples/installpaths.in | \
+ ${SED} 's:^:share/doc/gettext/:' > ${PLIST} && \
+ ${FIND} -d examples -type d | ${GREP} -v examples/po | \
+ ${SED} -e 's:^:@dirrm share/doc/gettext/:' \
+ >> ${PLIST}
+.endif
+ @${CAT} ${.CURDIR}/pkg-plist >> ${PLIST}
+
post-install:
.for f in po-compat.el po-mode.el
${INSTALL_DATA} ${WRKSRC}/gettext-tools/misc/${f} ${PREFIX}/share/emacs/site-lisp
.endfor
${MKDIR} ${X11BASE}/share/locale
+.if defined (WITH_EXAMPLES)
+ cd ${WRKSRC}/gettext-tools/examples && make install
+.endif
.include <bsd.port.post.mk>