aboutsummaryrefslogtreecommitdiff
path: root/devel/giggle
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-02-16 10:30:57 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-02-16 10:30:57 +0000
commit85171d97c93a28adb52ff0403bb760db775a67af (patch)
tree85110bd49bb1be10e3ba217717ac7a2ed73bd49a /devel/giggle
parent954579867f8d76c7e3438ddce62446e60ad6547b (diff)
downloadports-85171d97c93a28adb52ff0403bb760db775a67af.tar.gz
ports-85171d97c93a28adb52ff0403bb760db775a67af.zip
Notes
Diffstat (limited to 'devel/giggle')
-rw-r--r--devel/giggle/Makefile31
-rw-r--r--devel/giggle/distinfo6
-rw-r--r--devel/giggle/pkg-plist25
3 files changed, 43 insertions, 19 deletions
diff --git a/devel/giggle/Makefile b/devel/giggle/Makefile
index bb59aebcecfc..a3d9240e055c 100644
--- a/devel/giggle/Makefile
+++ b/devel/giggle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= giggle
-PORTVERSION= 0.4.91
-PORTREVISION= 2
+PORTVERSION= 0.4.96
CATEGORIES= devel
MASTER_SITES= GNOME
@@ -17,7 +16,8 @@ COMMENT= GTK+ frontend for git version control system
BUILD_DEPENDS= git:${PORTSDIR}/devel/git \
${SITE_PERL}/mach/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS= git:${PORTSDIR}/devel/git
-OPTIONS= EDS "Evolution Data Server support" on
+OPTIONS= EDS "Evolution Data Server support" On \
+ VTE "Terminal Widget" On
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -26,7 +26,23 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_EDS)
+CONFIGURE_ARGS+= --disable-evolution-data-server
+.elif defined(WITH_EDS)
+USE_GNOME+= evolutiondataserver
+.endif
+
+.if defined(WITH_VTE)
+USE_GNOME+= vte
+PLIST_SUB+= VTE=""
+.elif defined(WITHOUT_VTE)
+CONFIGURE_ARGS+= --disable-terminal
+PLIST_SUB+= VTE="@comment "
+.endif
.include <bsd.port.pre.mk>
@@ -34,10 +50,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
BROKEN= does not build
.endif
-.if defined(WITHOUT_EDS)
-CONFIGURE_ARGS+= --disable-evolution-data-server
-.elif defined(WITH_EDS)
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libebook-1.2.pc:${PORTSDIR}/databases/evolution-data-server
-.endif
+post-install:
+ @-update-desktop-database
.include <bsd.port.post.mk>
diff --git a/devel/giggle/distinfo b/devel/giggle/distinfo
index e05e56bc4bd6..2fb3ce76790a 100644
--- a/devel/giggle/distinfo
+++ b/devel/giggle/distinfo
@@ -1,3 +1,3 @@
-MD5 (giggle-0.4.91.tar.gz) = ea88213fa3c9cbf5c571dd17b0e430ea
-SHA256 (giggle-0.4.91.tar.gz) = 7ff4c5b7d679795c8e202c70c499481e53bfce9b0222ac1f34d02413dfb4b49f
-SIZE (giggle-0.4.91.tar.gz) = 561049
+MD5 (giggle-0.4.96.tar.gz) = 22ee0b91ee9c4c941cdcc0b5e14d65b9
+SHA256 (giggle-0.4.96.tar.gz) = 4086a3498a63dba68468f8a250f09989a66428d2b5ca1672383c92e26913eab8
+SIZE (giggle-0.4.96.tar.gz) = 616972
diff --git a/devel/giggle/pkg-plist b/devel/giggle/pkg-plist
index 791fd6b3e553..6017669d28e1 100644
--- a/devel/giggle/pkg-plist
+++ b/devel/giggle/pkg-plist
@@ -22,18 +22,20 @@ include/giggle/libgiggle-git/giggle-git-revisions.h
include/giggle/libgiggle-git/giggle-git.h
include/giggle/libgiggle/giggle-enums.h
include/giggle/libgiggle/giggle-marshal.h
-lib/giggle/plugins/libpersonal-details.la
-lib/giggle/plugins/libpersonal-details.so
-lib/giggle/plugins/libpersonal-details.so.0
-lib/giggle/plugins/personal-details.xml
-lib/libgiggle-0.4.91.so
-lib/libgiggle-git-0.4.91.so
+lib/giggle/plugins/0.4.96/libpersonal-details.la
+lib/giggle/plugins/0.4.96/libpersonal-details.so
+%%VTE%%lib/giggle/plugins/0.4.96/libterminal-view.la
+%%VTE%%lib/giggle/plugins/0.4.96/libterminal-view.so
+lib/giggle/plugins/0.4.96/personal-details.xml
+%%VTE%%lib/giggle/plugins/0.4.96/terminal-view.xml
lib/libgiggle-git.la
lib/libgiggle-git.so
+lib/libgiggle-git.so.0
lib/libgiggle.la
lib/libgiggle.so
+lib/libgiggle.so.0
share/applications/giggle.desktop
-%%DATADIR%%/glade/main-window.glade
+%%DATADIR%%/glade/main-window.ui
share/icons/hicolor/16x16/apps/giggle-branch.png
share/icons/hicolor/16x16/apps/giggle-history-view.png
share/icons/hicolor/16x16/apps/giggle-remote.png
@@ -43,6 +45,7 @@ share/icons/hicolor/16x16/apps/giggle-tag.png
share/icons/hicolor/16x16/apps/giggle.png
share/icons/hicolor/22x22/apps/giggle-history-view.png
share/icons/hicolor/22x22/apps/giggle.png
+share/icons/hicolor/24x24/apps/giggle-diff-view.png
share/icons/hicolor/24x24/apps/giggle-history-view.png
share/icons/hicolor/24x24/apps/giggle.png
share/icons/hicolor/32x32/apps/giggle-history-view.png
@@ -55,15 +58,23 @@ share/locale/de/LC_MESSAGES/giggle.mo
share/locale/en_GB/LC_MESSAGES/giggle.mo
share/locale/es/LC_MESSAGES/giggle.mo
share/locale/fr/LC_MESSAGES/giggle.mo
+share/locale/hu/LC_MESSAGES/giggle.mo
share/locale/ja/LC_MESSAGES/giggle.mo
+share/locale/pa/LC_MESSAGES/giggle.mo
share/locale/pl/LC_MESSAGES/giggle.mo
+share/locale/ru/LC_MESSAGES/giggle.mo
+share/locale/sl/LC_MESSAGES/giggle.mo
share/locale/sv/LC_MESSAGES/giggle.mo
share/locale/vi/LC_MESSAGES/giggle.mo
+share/locale/zh_CN/LC_MESSAGES/giggle.mo
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
@dirrmtry share/applications
+@dirrm lib/giggle/plugins/0.4.96
@dirrm lib/giggle/plugins
@dirrm lib/giggle
@dirrm include/giggle/libgiggle-git
@dirrm include/giggle/libgiggle
@dirrm include/giggle
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true