aboutsummaryrefslogtreecommitdiff
path: root/devel/git-cinnabar
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-06-04 15:25:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-06-04 15:25:35 +0000
commit692706b2dd4a626f7d3138dad38caea88359f7ce (patch)
treeef00dc4033afa615cf2f6e5916c711cbbb9f7a20 /devel/git-cinnabar
parent25d0f3cd86e83969a35fef38b2052b0ae6cc0d98 (diff)
downloadports-692706b2dd4a626f7d3138dad38caea88359f7ce.tar.gz
ports-692706b2dd4a626f7d3138dad38caea88359f7ce.zip
devel/git-cinnabar: unbreak after r537899
helper/cinnabar-fast-import.c:12:10: fatal error: 'sha1-array.h' file not found #include "sha1-array.h" ^~~~~~~~~~~~~~ In file included from helper/hg-connect-stdio.c:3: In file included from helper/hg-connect-internal.h:4: helper/hg-connect.h:6:10: fatal error: 'sha1-array.h' file not found #include "sha1-array.h" ^~~~~~~~~~~~~~ Obtained from: upstream
Notes
Notes: svn path=/head/; revision=537902
Diffstat (limited to 'devel/git-cinnabar')
-rw-r--r--devel/git-cinnabar/Makefile1
-rw-r--r--devel/git-cinnabar/files/patch-git-2.2757
2 files changed, 58 insertions, 0 deletions
diff --git a/devel/git-cinnabar/Makefile b/devel/git-cinnabar/Makefile
index a24ae95fc824..af3aa79ed52f 100644
--- a/devel/git-cinnabar/Makefile
+++ b/devel/git-cinnabar/Makefile
@@ -2,6 +2,7 @@
PORTNAME= git-cinnabar
DISTVERSION= 0.5.5
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
diff --git a/devel/git-cinnabar/files/patch-git-2.27 b/devel/git-cinnabar/files/patch-git-2.27
new file mode 100644
index 000000000000..e8b427414424
--- /dev/null
+++ b/devel/git-cinnabar/files/patch-git-2.27
@@ -0,0 +1,57 @@
+https://github.com/glandium/git-cinnabar/commit/81c1269f2e7d
+
+--- helper/GIT-VERSION.mk.orig 2020-04-23 06:16:13 UTC
++++ helper/GIT-VERSION.mk
+@@ -1,2 +1,2 @@
+-GIT_VERSION ?= v2.26.2
++GIT_VERSION ?= v2.27.0
+ WINDOWS_GIT_VERSION ?= $(GIT_VERSION).windows.1
+--- helper/cinnabar-fast-import.c.orig 2020-04-23 06:16:13 UTC
++++ helper/cinnabar-fast-import.c
+@@ -9,7 +9,7 @@ static void start_packfile();
+ #include "hg-bundle.h"
+ #include "hg-data.h"
+ #include "list.h"
+-#include "sha1-array.h"
++#include "oid-array.h"
+ #include "strslice.h"
+ #include "tree-walk.h"
+
+@@ -131,6 +131,8 @@ static void init()
+ avail_tree_table = xcalloc(avail_tree_table_sz, sizeof(struct avail_tree_content*));
+ marks = mem_pool_calloc(&fi_mem_pool, 1, sizeof(struct mark_set));
+
++ hashmap_init(&object_table, object_entry_hashcmp, NULL, 0);
++
+ global_argc = 1;
+
+ rc_free = mem_pool_alloc(&fi_mem_pool, cmd_save * sizeof(*rc_free));
+@@ -266,7 +268,7 @@ static uintmax_t parse_mark_ref(const char *p, char **
+ e->pack_id = MAX_PACK_ID;
+ e->idx.offset = 1;
+ }
+- insert_mark(2, e);
++ insert_mark(marks, 2, e);
+ return 2;
+ }
+
+@@ -462,7 +464,7 @@ static void do_set(struct string_list *args)
+
+ if (args->items[2].string[0] == ':') {
+ uintmax_t mark = parse_mark_ref_eol(args->items[2].string);
+- struct object_entry *oe = find_mark(mark);
++ struct object_entry *oe = find_mark(marks, mark);
+ oidcpy(&git_id, &oe->idx.oid);
+ } else if (get_oid_hex(args->items[2].string, &git_id))
+ die("Invalid sha1");
+--- helper/hg-connect.h.orig 2020-04-23 06:16:13 UTC
++++ helper/hg-connect.h
+@@ -3,7 +3,7 @@
+
+ #include "cinnabar-util.h"
+ #include "run-command.h"
+-#include "sha1-array.h"
++#include "oid-array.h"
+ #include "string-list.h"
+
+ struct hg_connection {