aboutsummaryrefslogtreecommitdiff
path: root/devel/git-review
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-11-04 15:42:34 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-11-04 15:42:34 +0000
commita4cea6ca196b46abe436dd5cc6eb6dc8b1023afa (patch)
treebe5a6223c28769ba6486a35ed30001639b66a5b6 /devel/git-review
parent43d9f2bd8f50ede8ebe4832a632a710cd8f102f9 (diff)
Add devel/git-review.
Git review allows you to extend git to interact more easily with a Gerrit server from the console. It allows you to push change to review, download a changeset into a new branch, push a change as draft or push an amended change as new patchset. PR: ports/173006 Submitted by: Sébastien Santoro aka Dereckson <dereckson@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306972
Diffstat (limited to 'devel/git-review')
-rw-r--r--devel/git-review/Makefile32
-rw-r--r--devel/git-review/distinfo2
-rw-r--r--devel/git-review/pkg-descr7
-rw-r--r--devel/git-review/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/git-review/Makefile b/devel/git-review/Makefile
new file mode 100644
index 000000000000..d514be4a7ed6
--- /dev/null
+++ b/devel/git-review/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= git-review
+PORTVERSION= 1.18
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+MASTER_SITE_SUBDIR= source/g/${PORTNAME}
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= Allow to push review and interact with a Gerrit server
+
+LICENSE= AL2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argparse>0:${PORTSDIR}/devel/py-argparse \
+ git:${PORTSDIR}/devel/git
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+MAN1= git-review.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/git-review ${PREFIX}/bin/git-review
+ ${INSTALL_MAN} ${WRKSRC}/git-review.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/HACKING ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/git-review/distinfo b/devel/git-review/distinfo
new file mode 100644
index 000000000000..92bd07a9233d
--- /dev/null
+++ b/devel/git-review/distinfo
@@ -0,0 +1,2 @@
+SHA256 (git-review-1.18.tar.gz) = 682b434a2eaf40e172728a9012bd0e461b892784f266e4829f55e3480f588772
+SIZE (git-review-1.18.tar.gz) = 17062
diff --git a/devel/git-review/pkg-descr b/devel/git-review/pkg-descr
new file mode 100644
index 000000000000..8b8854ab9f0b
--- /dev/null
+++ b/devel/git-review/pkg-descr
@@ -0,0 +1,7 @@
+Git review allows you to extend git to interact more easily with a Gerrit server
+from the console.
+
+It allows you to push change to review, download a changeset into a new branch,
+push a change as draft or push an amended change as new patchset.
+
+WWW: https://launchpad.net/git-review
diff --git a/devel/git-review/pkg-plist b/devel/git-review/pkg-plist
new file mode 100644
index 000000000000..235c615ea05a
--- /dev/null
+++ b/devel/git-review/pkg-plist
@@ -0,0 +1,5 @@
+bin/git-review
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/HACKING
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%@dirrm %%DOCSDIR%%