aboutsummaryrefslogtreecommitdiff
path: root/devel/gitlab-shell
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-13 13:40:38 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-13 13:40:38 +0000
commit07adcadb42c085d00d05a129c0cb6ff1639702c2 (patch)
tree13a61f695141c9b04f134ac65f47fcbcee9dd5c0 /devel/gitlab-shell
parentca040a7e0ca322ad825bad34a8f3e3222f1609f3 (diff)
Notes
Diffstat (limited to 'devel/gitlab-shell')
-rw-r--r--devel/gitlab-shell/Makefile31
-rw-r--r--devel/gitlab-shell/distinfo2
-rw-r--r--devel/gitlab-shell/files/patch-config.yml.example11
-rw-r--r--devel/gitlab-shell/pkg-descr4
-rw-r--r--devel/gitlab-shell/pkg-plist65
5 files changed, 113 insertions, 0 deletions
diff --git a/devel/gitlab-shell/Makefile b/devel/gitlab-shell/Makefile
new file mode 100644
index 000000000000..a47942d54207
--- /dev/null
+++ b/devel/gitlab-shell/Makefile
@@ -0,0 +1,31 @@
+# Created by: Torsten Zuehlsdorff <ports@toco-domains.de
+# $FreeBSD$
+
+PORTNAME= gitlab-shell
+PORTVERSION= 2.6.10
+CATEGORIES= devel
+MASTER_SITES= http://ports.toco-domains.de/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= ports@toco-domains.de
+COMMENT= GitLab Shell handles git commands for GitLab
+
+BUILD_DEPENDS= ruby>=2.1.5:${PORTSDIR}/lang/ruby21 \
+ gem:${PORTSDIR}/devel/ruby-gems
+
+USERS= git
+GROUPS= git
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-install:
+ ${MV} ${WRKSRC}/config.yml.example ${WRKSRC}/config.yml.sample
+
+post-install:
+ ${MKDIR} ${STAGEDIR}/var/log/
+ ${TOUCH} ${STAGEDIR}/var/log/gitlab-shell.log
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>
diff --git a/devel/gitlab-shell/distinfo b/devel/gitlab-shell/distinfo
new file mode 100644
index 000000000000..8aba954924dc
--- /dev/null
+++ b/devel/gitlab-shell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gitlab-shell-v2.6.10.tar.gz) = 25c4e05e6fb0068e4be6a6b44d5fe30b98957ea6fe1470fb622480354fb17bb7
+SIZE (gitlab-shell-v2.6.10.tar.gz) = 35474
diff --git a/devel/gitlab-shell/files/patch-config.yml.example b/devel/gitlab-shell/files/patch-config.yml.example
new file mode 100644
index 000000000000..3282b036414c
--- /dev/null
+++ b/devel/gitlab-shell/files/patch-config.yml.example
@@ -0,0 +1,11 @@
+--- config.yml.example.orig 2016-02-24 09:49:01 UTC
++++ config.yml.example
+@@ -48,7 +48,7 @@ redis:
+
+ # Log file.
+ # Default is gitlab-shell.log in the root directory.
+-# log_file: "/home/git/gitlab-shell/gitlab-shell.log"
++log_file: "/var/log/gitlab-shell.log"
+
+ # Log level. INFO by default
+ log_level: INFO
diff --git a/devel/gitlab-shell/pkg-descr b/devel/gitlab-shell/pkg-descr
new file mode 100644
index 000000000000..202da46f2040
--- /dev/null
+++ b/devel/gitlab-shell/pkg-descr
@@ -0,0 +1,4 @@
+GitLab Shell handles git commands for GitLab
+and modifies the list of authorized keys.
+
+WWW: https://gitlab.com/gitlab-org/gitlab-shell
diff --git a/devel/gitlab-shell/pkg-plist b/devel/gitlab-shell/pkg-plist
new file mode 100644
index 000000000000..d5f9352bbdf6
--- /dev/null
+++ b/devel/gitlab-shell/pkg-plist
@@ -0,0 +1,65 @@
+%%DATADIR%%/.gitignore
+%%DATADIR%%/.gitlab-ci.yml
+%%DATADIR%%/.hound.yml
+%%DATADIR%%/.rspec
+%%DATADIR%%/.rubocop.yml
+%%DATADIR%%/CHANGELOG
+%%DATADIR%%/Gemfile
+%%DATADIR%%/Gemfile.lock
+%%DATADIR%%/Guardfile
+%%DATADIR%%/LICENSE
+%%DATADIR%%/README.md
+%%DATADIR%%/VERSION
+@(git,,555) %%DATADIR%%/bin/check
+@(git,,555) %%DATADIR%%/bin/create-hooks
+@(git,,555) %%DATADIR%%/bin/gitlab-keys
+@(git,,555) %%DATADIR%%/bin/gitlab-projects
+@(git,,555) %%DATADIR%%/bin/gitlab-shell
+@(git,,555) %%DATADIR%%/bin/install
+@sample %%DATADIR%%/config.yml.sample
+%%DATADIR%%/hooks/post-receive
+%%DATADIR%%/hooks/pre-receive
+%%DATADIR%%/hooks/update
+%%DATADIR%%/lib/gitlab_access.rb
+%%DATADIR%%/lib/gitlab_access_status.rb
+%%DATADIR%%/lib/gitlab_config.rb
+%%DATADIR%%/lib/gitlab_custom_hook.rb
+%%DATADIR%%/lib/gitlab_init.rb
+%%DATADIR%%/lib/gitlab_keys.rb
+%%DATADIR%%/lib/gitlab_logger.rb
+%%DATADIR%%/lib/gitlab_net.rb
+%%DATADIR%%/lib/gitlab_post_receive.rb
+%%DATADIR%%/lib/gitlab_projects.rb
+%%DATADIR%%/lib/gitlab_shell.rb
+%%DATADIR%%/lib/httpunix.rb
+%%DATADIR%%/lib/names_helper.rb
+%%DATADIR%%/spec/gitlab_access_spec.rb
+%%DATADIR%%/spec/gitlab_config_spec.rb
+%%DATADIR%%/spec/gitlab_keys_spec.rb
+%%DATADIR%%/spec/gitlab_logger_spec.rb
+%%DATADIR%%/spec/gitlab_net_spec.rb
+%%DATADIR%%/spec/gitlab_post_receive_spec.rb
+%%DATADIR%%/spec/gitlab_projects_spec.rb
+%%DATADIR%%/spec/gitlab_shell_spec.rb
+%%DATADIR%%/spec/httpunix_spec.rb
+%%DATADIR%%/spec/names_helper_spec.rb
+%%DATADIR%%/spec/spec_helper.rb
+%%DATADIR%%/spec/vcr_cassettes/allowed-pull.yml
+%%DATADIR%%/spec/vcr_cassettes/allowed-push.yml
+%%DATADIR%%/spec/vcr_cassettes/broadcast_message-none.yml
+%%DATADIR%%/spec/vcr_cassettes/broadcast_message-ok.yml
+%%DATADIR%%/spec/vcr_cassettes/check-ok.yml
+%%DATADIR%%/spec/vcr_cassettes/denied-pull.yml
+%%DATADIR%%/spec/vcr_cassettes/denied-push-with-user.yml
+%%DATADIR%%/spec/vcr_cassettes/denied-push.yml
+%%DATADIR%%/spec/vcr_cassettes/discover-ok.yml
+%%DATADIR%%/support/rewrite-hooks.sh
+%%DATADIR%%/support/truncate_repositories.sh
+@(git,,664) /var/log/gitlab-shell.log
+@dir %%DATADIR%%/bin
+@dir %%DATADIR%%/hooks
+@dir %%DATADIR%%/lib
+@dir %%DATADIR%%/spec/vcr_cassettes
+@dir %%DATADIR%%/spec
+@dir %%DATADIR%%/support
+@dir %%DATADIR%%