aboutsummaryrefslogtreecommitdiff
path: root/devel/glademm/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2005-04-25 04:31:04 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2005-04-25 04:31:04 +0000
commit46f7035f125cf4a833ebdb69f6e9a42037af68c0 (patch)
treefc8ba555f6f601136fe059c59d0f7550b889fdac /devel/glademm/Makefile
parentd1d8cfff951e3eee01a8475a3a057ca2c6dca2d4 (diff)
downloadports-46f7035f125cf4a833ebdb69f6e9a42037af68c0.tar.gz
ports-46f7035f125cf4a833ebdb69f6e9a42037af68c0.zip
Notes
Diffstat (limited to 'devel/glademm/Makefile')
-rw-r--r--devel/glademm/Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/devel/glademm/Makefile b/devel/glademm/Makefile
index abfca1ced425..f5932cd9653c 100644
--- a/devel/glademm/Makefile
+++ b/devel/glademm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= glademm
-PORTVERSION= 2.0.0.1
-PORTREVISION= 2
+PORTVERSION= 2.6.0
CATEGORIES= devel gnome
MASTER_SITES= http://home.wtal.de/petig/Gtk/
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
@@ -19,19 +18,24 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnometarget
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER= 15
USE_GETOPT_LONG= yes
+PLIST_FILES= bin/glade-- bin/glademm-embed
+
.include <bsd.port.pre.mk>
post-patch:
- ${RM} -f ${WRKSRC}/src/getopt.*
+ @${RM} -f ${WRKSRC}/src/getopt.*
+ @${REINPLACE_CMD} \
+ -Ee '/^@AMDEP/!s|getopt([^[:space:]])+||g' \
+ -Ee '/^@AMDEP(.)+getopt/d' \
+ ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} \
- -e 's|automake-1.7|automake18|g' \
- -e 's|automake-1.5|automake15|g' \
- -e 's|automake-1.4|automake14|g' \
- -e 's|autoconf2.50|autoconf259|g' \
- -e 's|autoconf2.13|autoconf213|g' \
- ${WRKSRC}/src/glade--.cc
+ -Ee 's|automake-([[:digit:]]+)\.([[:digit:]]+)|automake\1\2|g' \
+ -e 's|autoconf2\.50|autoconf259|g' \
+ -e 's|autoconf2\.13|autoconf213|g' \
+ ${WRKSRC}/src/glade--.cc \
+ ${WRKSRC}/src/Cxx.cc
.include <bsd.port.post.mk>