aboutsummaryrefslogtreecommitdiff
path: root/devel/glib20
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-10-17 17:16:33 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-10-17 17:16:33 +0000
commitdf15d247276788663fc6b5208e6cf3b784ce76c2 (patch)
treef4d3e928f2e221d841a2d54c3ce00be1bd197271 /devel/glib20
parentcda622b482c818b0f5ed000cf5ced80d829e303a (diff)
Re-enable kqueue backend for file monitoring. But add a hack, it
should allow programs to work properly again. PR: 202128
Notes
Notes: svn path=/head/; revision=399544
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile5
-rw-r--r--devel/glib20/files/patch-gio_gunionvolumemonitor.c16
2 files changed, 18 insertions, 3 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 18333b663f22..d89d04842be4 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -3,7 +3,7 @@
PORTNAME= glib
PORTVERSION= 2.44.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -33,8 +33,7 @@ CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
--enable-static=yes \
--with-pcre=system \
--disable-fam
-CONFIGURE_ENV= ac_cv_header_sys_inotify_h= \
- ac_cv_header_sys_event_h=
+CONFIGURE_ENV= ac_cv_header_sys_inotify_h=
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
diff --git a/devel/glib20/files/patch-gio_gunionvolumemonitor.c b/devel/glib20/files/patch-gio_gunionvolumemonitor.c
new file mode 100644
index 000000000000..2749dca027cb
--- /dev/null
+++ b/devel/glib20/files/patch-gio_gunionvolumemonitor.c
@@ -0,0 +1,16 @@
+https://bugzilla.gnome.org/show_bug.cgi?id=753378
+
+--- gio/gunionvolumemonitor.c.orig 2015-09-25 11:23:00.429587000 +0200
++++ gio/gunionvolumemonitor.c 2015-09-25 11:23:12.787618000 +0200
+@@ -592,9 +592,9 @@ _g_mount_get_for_mount_path (const gchar
+
+ if (klass->get_mount_for_mount_path)
+ {
+- g_rec_mutex_lock (&the_volume_monitor_mutex);
++// g_rec_mutex_lock (&the_volume_monitor_mutex);
+ mount = klass->get_mount_for_mount_path (mount_path, cancellable);
+- g_rec_mutex_unlock (&the_volume_monitor_mutex);
++// g_rec_mutex_unlock (&the_volume_monitor_mutex);
+ }
+
+ /* TODO: How do we know this succeeded? Keep in mind that the native