aboutsummaryrefslogtreecommitdiff
path: root/devel/glib20
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-11-13 17:51:58 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-11-13 17:51:58 +0000
commite11321093c84d5f085b42d97c120f7043772b9cb (patch)
treec06e12684bf776c9c6255b0edc1bc162ec559b5b /devel/glib20
parent4569a6ff3b8d909e9a7bd5542ff4e246fff10950 (diff)
downloadports-e11321093c84d5f085b42d97c120f7043772b9cb.tar.gz
ports-e11321093c84d5f085b42d97c120f7043772b9cb.zip
Update glib20 to 2.56.3.
* Add MANPAGES options to build the manpages as they don't come pre-build anymore. Obtained from: GNOME devel repo.
Notes
Notes: svn path=/head/; revision=484886
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile24
-rw-r--r--devel/glib20/distinfo6
-rw-r--r--devel/glib20/files/patch-gio_kqueue_Makefile.in32
-rw-r--r--devel/glib20/pkg-plist30
4 files changed, 53 insertions, 39 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index f8f4f979e924..f8e91d364e8b 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= glib
-PORTVERSION= 2.56.1
-PORTREVISION= 3
+PORTVERSION= 2.56.3
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= GNOME
@@ -30,7 +29,6 @@ USES+= compiler:c11 gettext gmake gnome iconv:wchar_t libtool \
localbase pathfix perl5 pkgconfig python shebangfix
USE_PYTHON= py3kplist
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
- --disable-man --without-xml-catalog \
--enable-static=yes \
--with-pcre=system \
--disable-fam
@@ -39,7 +37,7 @@ INSTALL_TARGET= install-strip
SHEBANG_FILES= */*.pl
-LIBVERSION= 0.5600.1
+LIBVERSION= 0.5600.3
PLIST_SUB+= LIBVERSION=${LIBVERSION}
glib_MAN= gtester.1 gtester-report.1 glib-gettextize.1
@@ -48,11 +46,18 @@ gio_MAN= gdbus.1 gsettings.1 gio-querymodules.1 gio.1 \
glib-compile-resources.1 gresource.1 gdbus-codegen.1
gobject_MAN= glib-genmarshal.1 glib-mkenums.1 gobject-query.1
-OPTIONS_DEFINE= DEBUG NLS
+OPTIONS_DEFINE= DEBUG MANPAGES NLS
+OPTIONS_DEFAULT= MANPAGES
OPTIONS_SUB= yes
DEBUG_CONFIGURE_ON= --enable-debug=yes
+MANPAGES_BUILD_DEPENDS= docbook-xml>4.1.2:textproc/docbook-xml \
+ docbook-xsl>0:textproc/docbook-xsl
+MANPAGES_USE= GNOME=libxslt:build
+MANPAGES_CONFIGURE_ENABLE= man
+MANPAGES_CONFIGURE_ON= --with-xml-catalog=${LOCALBASE}/share/xml/catalog
+
.include <bsd.port.pre.mk>
# doesn't build yet
@@ -86,9 +91,18 @@ post-patch:
s|-Werror|| ; \
s|#define HAVE_SYS_INOTIFY_H 1||' ${WRKSRC}/configure
+do-build-MANPAGES-on:
+.for m in glib gio gobject
+. for file in ${${m}_MAN}
+ cd ${WRKSRC}/docs/reference/${m} && ${GMAKE} ${file}
+. endfor
+.endfor
+
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/GConf/gsettings
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/gio/modules
+
+post-install-MANPAGES-on:
.for m in glib gio gobject
${INSTALL_MAN} ${${m}_MAN:S|^|${WRKSRC}/docs/reference/${m}/|} \
${STAGEDIR}${PREFIX}/man/man1
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index 767d2d841551..b7aa2b1449fa 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1525371429
-SHA256 (gnome2/glib-2.56.1.tar.xz) = 40ef3f44f2c651c7a31aedee44259809b6f03d3d20be44545cd7d177221c0b8d
-SIZE (gnome2/glib-2.56.1.tar.xz) = 8028716
+TIMESTAMP = 1538415400
+SHA256 (gnome2/glib-2.56.3.tar.xz) = a9a4c5b4c81b6c75bc140bdf5e32120ef3ce841b7413214ecf5f987acec74cb2
+SIZE (gnome2/glib-2.56.3.tar.xz) = 7009912
diff --git a/devel/glib20/files/patch-gio_kqueue_Makefile.in b/devel/glib20/files/patch-gio_kqueue_Makefile.in
index 4e2a220ba9f7..2492deab225e 100644
--- a/devel/glib20/files/patch-gio_kqueue_Makefile.in
+++ b/devel/glib20/files/patch-gio_kqueue_Makefile.in
@@ -1,6 +1,6 @@
---- gio/kqueue/Makefile.in.orig 2018-04-09 23:09:21.018712000 +0200
-+++ gio/kqueue/Makefile.in 2018-04-09 23:09:38.517739000 +0200
-@@ -183,9 +183,7 @@ LTLIBRARIES = $(installed_test_LTLIBRARIES) $(noinst_L
+--- gio/kqueue/Makefile.in.orig 2018-10-01 19:39:31.421019000 +0200
++++ gio/kqueue/Makefile.in 2018-10-01 19:43:01.841725000 +0200
+@@ -187,9 +187,7 @@ LTLIBRARIES = $(installed_test_LTLIBRARIES) $(noinst_L
libkqueue_la_LIBADD =
am__objects_1 =
am_libkqueue_la_OBJECTS = libkqueue_la-gkqueuefilemonitor.lo \
@@ -11,7 +11,7 @@
libkqueue_la-dep-list.lo $(am__objects_1)
libkqueue_la_OBJECTS = $(am_libkqueue_la_OBJECTS)
AM_V_lt = $(am__v_lt_@AM_V@)
-@@ -777,19 +775,9 @@ all_test_ltlibs = $(test_ltlibraries) $(uninstalled_te
+@@ -785,19 +783,9 @@ all_test_ltlibs = $(test_ltlibraries) $(uninstalled_te
@ENABLE_INSTALLED_TESTS_TRUE@installed_test_meta_DATA = $(installed_testcases:=.test)
libkqueue_la_SOURCES = \
gkqueuefilemonitor.c \
@@ -31,20 +31,20 @@
dep-list.c \
dep-list.h \
$(NULL)
-@@ -1009,12 +997,8 @@ distclean-compile:
+@@ -1017,12 +1005,8 @@ distclean-compile:
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-dep-list.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-gkqueuefilemonitor.Plo@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-exclusions.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-helper.Plo@am__quote@
- @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-missing.Plo@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-sub.Plo@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-thread.Plo@am__quote@
--@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-utils.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-dep-list.Plo@am__quote@ # am--include-marker
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-gkqueuefilemonitor.Plo@am__quote@ # am--include-marker
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-exclusions.Plo@am__quote@ # am--include-marker
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-helper.Plo@am__quote@ # am--include-marker
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-missing.Plo@am__quote@ # am--include-marker
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-sub.Plo@am__quote@ # am--include-marker
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-thread.Plo@am__quote@ # am--include-marker
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libkqueue_la-kqueue-utils.Plo@am__quote@ # am--include-marker
- .c.o:
- @am__fastdepCC_TRUE@ $(AM_V_CC)depbase=`echo $@ | sed 's|[^/]*$$|$(DEPDIR)/&|;s|\.o$$||'`;\
-@@ -1054,40 +1038,12 @@ libkqueue_la-kqueue-helper.lo: kqueue-helper.c
+ $(am__depfiles_remade):
+ @$(MKDIR_P) $(@D)
+@@ -1068,40 +1052,12 @@ libkqueue_la-kqueue-helper.lo: kqueue-helper.c
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libkqueue_la_CFLAGS) $(CFLAGS) -c -o libkqueue_la-kqueue-helper.lo `test -f 'kqueue-helper.c' || echo '$(srcdir)/'`kqueue-helper.c
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index 5215fc842ab5..5882640a2f62 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -304,21 +304,21 @@ libdata/pkgconfig/gmodule-export-2.0.pc
libdata/pkgconfig/gmodule-no-export-2.0.pc
libdata/pkgconfig/gobject-2.0.pc
libdata/pkgconfig/gthread-2.0.pc
-man/man1/gapplication.1.gz
-man/man1/gdbus-codegen.1.gz
-man/man1/gdbus.1.gz
-man/man1/gio-querymodules.1.gz
-man/man1/gio.1.gz
-man/man1/glib-compile-resources.1.gz
-man/man1/glib-compile-schemas.1.gz
-man/man1/glib-genmarshal.1.gz
-man/man1/glib-gettextize.1.gz
-man/man1/glib-mkenums.1.gz
-man/man1/gobject-query.1.gz
-man/man1/gresource.1.gz
-man/man1/gsettings.1.gz
-man/man1/gtester-report.1.gz
-man/man1/gtester.1.gz
+%%MANPAGES%%man/man1/gapplication.1.gz
+%%MANPAGES%%man/man1/gdbus-codegen.1.gz
+%%MANPAGES%%man/man1/gdbus.1.gz
+%%MANPAGES%%man/man1/gio-querymodules.1.gz
+%%MANPAGES%%man/man1/gio.1.gz
+%%MANPAGES%%man/man1/glib-compile-resources.1.gz
+%%MANPAGES%%man/man1/glib-compile-schemas.1.gz
+%%MANPAGES%%man/man1/glib-genmarshal.1.gz
+%%MANPAGES%%man/man1/glib-gettextize.1.gz
+%%MANPAGES%%man/man1/glib-mkenums.1.gz
+%%MANPAGES%%man/man1/gobject-query.1.gz
+%%MANPAGES%%man/man1/gresource.1.gz
+%%MANPAGES%%man/man1/gsettings.1.gz
+%%MANPAGES%%man/man1/gtester-report.1.gz
+%%MANPAGES%%man/man1/gtester.1.gz
share/aclocal/glib-2.0.m4
share/aclocal/glib-gettext.m4
share/aclocal/gsettings.m4