aboutsummaryrefslogtreecommitdiff
path: root/devel/gmake
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2011-04-11 19:54:35 +0000
committerAde Lovett <ade@FreeBSD.org>2011-04-11 19:54:35 +0000
commitfe0d23d638e55fd3fbfe8e6f43b0f6d26c8b713f (patch)
tree6b96a59b96237deb8710fe2065d0c3393e7088bc /devel/gmake
parent9cdeec96c134d87226d71d31195c647c6b761885 (diff)
downloadports-fe0d23d638e55fd3fbfe8e6f43b0f6d26c8b713f.tar.gz
ports-fe0d23d638e55fd3fbfe8e6f43b0f6d26c8b713f.zip
Notes
Diffstat (limited to 'devel/gmake')
-rw-r--r--devel/gmake/Makefile3
-rw-r--r--devel/gmake/distinfo5
-rw-r--r--devel/gmake/files/patch-ab15
-rw-r--r--devel/gmake/files/patch-make.h12
-rw-r--r--devel/gmake/files/patch-read.c52
-rw-r--r--devel/gmake/pkg-plist5
6 files changed, 61 insertions, 31 deletions
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index 10bb1943d67b..d48342ab0494 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmake
-PORTVERSION= 3.81
-PORTREVISION= 4
+PORTVERSION= 3.82
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= make
diff --git a/devel/gmake/distinfo b/devel/gmake/distinfo
index a6410079661f..6f75d6baced1 100644
--- a/devel/gmake/distinfo
+++ b/devel/gmake/distinfo
@@ -1,3 +1,2 @@
-MD5 (make-3.81.tar.bz2) = 354853e0b2da90c527e35aabb8d6f1e6
-SHA256 (make-3.81.tar.bz2) = f3e69023771e23908f5d5592954d8271d3d6af09693cecfd29cee6fde8550dc8
-SIZE (make-3.81.tar.bz2) = 1151445
+SHA256 (make-3.82.tar.bz2) = e2c1a73f179c40c71e2fe8abf8a8a0688b8499538512984da4a76958d0402966
+SIZE (make-3.82.tar.bz2) = 1242186
diff --git a/devel/gmake/files/patch-ab b/devel/gmake/files/patch-ab
index 4d7d9551e18b..f4bcc7661b0c 100644
--- a/devel/gmake/files/patch-ab
+++ b/devel/gmake/files/patch-ab
@@ -1,14 +1,7 @@
---- doc/make.texi.orig Mon Oct 7 22:57:59 2002
-+++ doc/make.texi Mon Oct 7 22:58:03 2002
-@@ -25,9 +25,9 @@
- @c Combine the program and concept indices:
- @syncodeindex pg cp
-
--@dircategory GNU Packages
-+@dircategory Programming & development tools
+--- doc/make.texi.orig 2010-07-19 02:10:54.000000000 -0500
++++ doc/make.texi 2011-03-02 17:01:58.000000000 -0600
+@@ -54,3 +54,3 @@
@direntry
-* Make: (make). Remake files automatically.
-+* GNU make: (make). Remake files automatically.
++* GNU Make: (make). Remake files automatically.
@end direntry
-
- @ifinfo
diff --git a/devel/gmake/files/patch-make.h b/devel/gmake/files/patch-make.h
deleted file mode 100644
index 28a63d2eb076..000000000000
--- a/devel/gmake/files/patch-make.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- make.h.orig Wed Sep 11 18:55:44 2002
-+++ make.h Mon Oct 21 22:05:11 2002
-@@ -33,7 +33,7 @@
- # ifdef _AIX
- #pragma alloca
- # else
--# ifndef alloca /* predefined by HP cc +Olibcalls */
-+# if !defined (alloca) && !defined (__FreeBSD__) /* predefined by HP cc +Olibcalls, part of stdlib.h on FreeBSD */
- char *alloca ();
- # endif
- # endif
-
diff --git a/devel/gmake/files/patch-read.c b/devel/gmake/files/patch-read.c
new file mode 100644
index 000000000000..4ca91c48663c
--- /dev/null
+++ b/devel/gmake/files/patch-read.c
@@ -0,0 +1,52 @@
+Add a fix for bug #30612 (http://savannah.gnu.org/bugs/index.php?30612)
+from GNU make's CVS repository (revision 1.194).
+
+Taken from pkgsrc repository: devel/gmake/patches/patch-ah
+
+--- read.c.orig 2010-07-13 01:20:42.000000000 +0000
++++ read.c
+@@ -3028,7 +3028,7 @@ parse_file_seq (char **stringp, unsigned
+ {
+ /* This looks like the first element in an open archive group.
+ A valid group MUST have ')' as the last character. */
+- const char *e = p + nlen;
++ const char *e = p;
+ do
+ {
+ e = next_token (e);
+@@ -3084,19 +3084,19 @@ parse_file_seq (char **stringp, unsigned
+ Go to the next item in the string. */
+ if (flags & PARSEFS_NOGLOB)
+ {
+- NEWELT (concat (2, prefix, tp));
++ NEWELT (concat (2, prefix, tmpbuf));
+ continue;
+ }
+
+ /* If we get here we know we're doing glob expansion.
+ TP is a string in tmpbuf. NLEN is no longer used.
+ We may need to do more work: after this NAME will be set. */
+- name = tp;
++ name = tmpbuf;
+
+ /* Expand tilde if applicable. */
+- if (tp[0] == '~')
++ if (tmpbuf[0] == '~')
+ {
+- tildep = tilde_expand (tp);
++ tildep = tilde_expand (tmpbuf);
+ if (tildep != 0)
+ name = tildep;
+ }
+@@ -3152,7 +3152,10 @@ parse_file_seq (char **stringp, unsigned
+ else
+ {
+ /* We got a chain of items. Attach them. */
+- (*newp)->next = found;
++ if (*newp)
++ (*newp)->next = found;
++ else
++ *newp = found;
+
+ /* Find and set the new end. Massage names if necessary. */
+ while (1)
diff --git a/devel/gmake/pkg-plist b/devel/gmake/pkg-plist
index 596ac18a9553..d2135903549e 100644
--- a/devel/gmake/pkg-plist
+++ b/devel/gmake/pkg-plist
@@ -10,17 +10,16 @@ bin/gmake
%%NLS%%share/locale/he/LC_MESSAGES/make.mo
%%NLS%%share/locale/hr/LC_MESSAGES/make.mo
%%NLS%%share/locale/id/LC_MESSAGES/make.mo
+%%NLS%%share/locale/it/LC_MESSAGES/make.mo
%%NLS%%share/locale/ja/LC_MESSAGES/make.mo
%%NLS%%share/locale/ko/LC_MESSAGES/make.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/make.mo
%%NLS%%share/locale/nl/LC_MESSAGES/make.mo
%%NLS%%share/locale/pl/LC_MESSAGES/make.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/make.mo
%%NLS%%share/locale/ru/LC_MESSAGES/make.mo
-%%NLS%%share/locale/rw/LC_MESSAGES/make.mo
%%NLS%%share/locale/sv/LC_MESSAGES/make.mo
%%NLS%%share/locale/tr/LC_MESSAGES/make.mo
%%NLS%%share/locale/uk/LC_MESSAGES/make.mo
%%NLS%%share/locale/vi/LC_MESSAGES/make.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/make.mo
-%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/rw