aboutsummaryrefslogtreecommitdiff
path: root/devel/gnu-automake/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-17 06:37:35 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-17 06:37:35 +0000
commit94f9acd994fe8f3d1e1d7f854bd7e775d92022d9 (patch)
treec0ea038e8ed7cd0bf93b7f4118bc345c1c5b3b82 /devel/gnu-automake/Makefile
parent3149844a48dfe367568c7781bbb3ba25de673547 (diff)
downloadports-94f9acd994fe8f3d1e1d7f854bd7e775d92022d9.tar.gz
ports-94f9acd994fe8f3d1e1d7f854bd7e775d92022d9.zip
Notes
Diffstat (limited to 'devel/gnu-automake/Makefile')
-rw-r--r--devel/gnu-automake/Makefile47
1 files changed, 15 insertions, 32 deletions
diff --git a/devel/gnu-automake/Makefile b/devel/gnu-automake/Makefile
index db816b2595fa..41aec899452f 100644
--- a/devel/gnu-automake/Makefile
+++ b/devel/gnu-automake/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: automake19
+# New ports collection makefile for: automake18
# Date created: 15 Feb 2003
# Whom: Udo Schweigert
#
@@ -6,48 +6,31 @@
#
PORTNAME= automake
-PORTVERSION= 1.9.2
+PORTVERSION= 1.8.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= automake
+PKGNAMEPREFIX= gnu-
DISTNAME= automake-${PORTVERSION}
-MAINTAINER= ade@FreeBSD.org
-COMMENT= GNU Standards-compliant Makefile generator (version 1.9)
+MAINTAINER= marcus@FreeBSD.org
+COMMENT= GNU Standards-compliant Makefile generator (version 1.8)
+
+BUILD_DEPENDS= ${LOCALBASE}/gnu-autotools/bin/autoconf:${PORTSDIR}/devel/gnu-autoconf
+RUN_DEPENDS= ${LOCALBASE}/gnu-autotools/bin/autoconf:${PORTSDIR}/devel/gnu-autoconf
+
+PREFIX?= ${LOCALBASE}/gnu-autotools
-WANT_AUTOCONF_VER=259
-WANT_AUTOCONF_RUN=yes
-BUILD_VERSION= 19
-PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
-LATEST_LINK= automake${BUILD_VERSION}
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= AUTOCONF=autoconf259 AUTOHEADER=autoheader259 MAKEINFO=makeinfo
-CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION}
+NO_MTREE= yes
+CONFIGURE_ENV= AUTOCONF=${LOCALBASE}/gnu-autotools/bin/autoconf \
+ AUTOHEADER=${LOCALBASE}/gnu-autotools/bin/autoheader \
+ MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_REINPLACE= yes
-INFO= automake${BUILD_VERSION}
-
-post-patch:
- @(cd ${WRKSRC}/doc && \
- ${RM} -f *.info && \
- ${MV} automake.texi automake${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(automake)\.(info),\1${BUILD_VERSION}\.\2,g' automake${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(automake)\.(info|texi),\1${BUILD_VERSION}\.\2,g' Makefile.in \
- )
- @${REINPLACE_CMD} -e 's,%%X11BASE%%,${X11BASE},g' ${WRKSRC}/aclocal.in
-
-pre-install:
- @${RM} -fr ${PREFIX}/share/automake${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/share/automake${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/share/aclocal${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/libexec/automake${BUILD_VERSION}
post-install:
-.for i in aclocal automake
- @${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} \
- ${PREFIX}/libexec/automake${BUILD_VERSION}/${i}
-.endfor
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>